Install manifest
[platform/upstream/atk.git] / packaging / atk.spec
index 27f74d2..0748a4c 100644 (file)
@@ -1,18 +1,20 @@
-%bcond_with introspection
-
+%define baseline 2.16
 Name:           atk
-Version:        2.8.0
+Version:        2.16.0
 Release:        0
-License:        LGPL-2.1+
+License:        LGPL-2.0+
 Summary:        An Accessibility ToolKit
 Url:            http://www.gtk.org/
 Group:          System/Libraries
-Source:         http://download.gnome.org/sources/atk/2.8/%{name}-%{version}.tar.xz
+Source:         http://download.gnome.org/sources/%{name}/%{baseline}/%{name}-%{version}.tar.xz
 Source98:       baselibs.conf
-Source1001:    atk.manifest
+Source1001:     %{name}.manifest
+
 BuildRequires:  fdupes
 BuildRequires:  gcc-c++
 BuildRequires:  glib2-devel >= 2.35.2
+BuildRequires:  intltool
+BuildRequires:  which
 %if %{with introspection}
 BuildRequires:  gobject-introspection-devel
 %endif
@@ -47,23 +49,19 @@ This package provides the GObject Introspection bindings for ATK.
 
 %package devel
 Summary:        Include Files and Libraries mandatory for Development
-Group:          Development/Gnome
+Group:          Development/Libraries/GNOME
 Requires:       libatk = %{version}
-%if %{with introspection}
-Requires:       typelib-Atk = %{version}
-%endif
 
 %description devel
 This package contains all necessary include files and libraries needed
 to develop applications that require these.
 
-
 %prep
 %setup -q
 cp %{SOURCE1001} .
 
 %build
-%configure \
+%autogen \
   --disable-static
 make %{?_smp_mflags}
 
@@ -71,6 +69,9 @@ make %{?_smp_mflags}
 %make_install
 %fdupes %{buildroot}
 
+mkdir -p %{buildroot}/usr/share/license
+cp -f COPYING %{buildroot}/usr/share/license/%{name}
+
 %post -n libatk -p /sbin/ldconfig
 
 %postun -n libatk -p /sbin/ldconfig
@@ -78,25 +79,14 @@ make %{?_smp_mflags}
 %files -n libatk
 %manifest %{name}.manifest
 %defattr(-, root, root)
-%license COPYING
+%doc COPYING
+/usr/share/license/%{name}
 %{_libdir}/lib*.so.*
 
-
-%if %{with introspection}
-%files -n typelib-Atk
-%manifest %{name}.manifest
-%defattr(-, root, root)
-%{_libdir}/girepository-1.0/Atk-1.0.typelib
-%endif
-
 %files devel
 %manifest %{name}.manifest
 %defattr(-, root, root)
 %{_includedir}/atk-1.0
 %{_libdir}/lib*.so
 %{_libdir}/pkgconfig/*.pc
-%if %{with introspection}
-%{_datadir}/gir-1.0/*.gir
-%endif
 
-%docs_package