Setting low log level by default.
[platform/adaptation/rpi3/arm-trusted-firmware-rpi3.git] / packaging / arm-trusted-firmware.spec
index d05b111..a5451ee 100644 (file)
@@ -1,11 +1,10 @@
 %define buildplat rpi3
-%define builddbg  1
-%if %{builddbg} == 1
+%if "%{build_type}" == "DEBUG"
 %define buildtype debug
 %define compile_flags BUILD_STRING="" LOG_LEVEL=40 DEBUG=1 V=0 CRASH_REPORTING=1 SPD=opteed
 %else
 %define buildtype release
-%define compile_flags BUILD_STRING="" LOG_LEVEL=20 DEBUG=0 V=0 CRASH_REPORTING=1 SPD=opteed
+%define compile_flags BUILD_STRING="" LOG_LEVEL=10 DEBUG=0 V=0 CRASH_REPORTING=1 SPD=opteed
 %endif
 
 Name: atf-rpi3