Add to check condition for emulator in spec file
[platform/framework/native/certificate-selector.git] / packaging / apps.CertificateSelector.spec
index 5f02a90..df53e95 100644 (file)
@@ -1,7 +1,7 @@
 Name:                  apps.CertificateSelector
 Summary:               The app-control of the certificate manager
-Version:               1.2.1.0
-Release:               2
+Version:               1.2.2.0
+Release:               1
 Group:                 TO_BE/FILLED_IN
 License:               Apache License, Version 2.0
 Source0:               %{name}-%{version}.tar.gz
@@ -9,9 +9,13 @@ BuildRequires: cmake
 BuildRequires: pkgconfig(osp-appfw)
 BuildRequires: osp-appfw-internal-devel
 BuildRequires: pkgconfig(osp-uifw)
+BuildRequires:  hash-signer
 
+# smack domain requires
+Requires(post):        osp-security-service
+
+# runtime requires
 Requires:              chromium
-Requires:              osp-security-service
 Requires:              pkgmgr
 
 %description
@@ -23,8 +27,12 @@ The app-control of the certificate manager
 %build
 MAJORVER=`echo %{version} | awk 'BEGIN {FS="."}{print $1}'`
 %ifarch %{ix86}
+%if 0%{?simulator}
 CXXFLAGS="$CXXFLAGS -D_OSP_DEBUG_ -D_OSP_X86_ -D_OSP_EMUL_" cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix}
 %else
+CXXFLAGS="$CXXFLAGS -D_OSP_DEBUG_ -D_OSP_X86_ " cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix}
+%endif
+%else
 CXXFLAGS="-O2 -g -pipe -Wall -fno-exceptions -Wformat -Wformat-security -Wl,--as-needed -fmessage-length=0 -march=armv7-a -mtune=cortex-a8 -mlittle-endian -mfpu=neon -mfloat-abi=softfp -D__SOFTFP__ -mthumb -Wa,-mimplicit-it=thumb -funwind-tables -D_OSP_DEBUG_ -D_OSP_ARMEL_" cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix}
 %endif
 
@@ -37,18 +45,20 @@ mkdir -p %{buildroot}/usr/share/license
 cp %{_builddir}/%{name}-%{version}/LICENSE.Apache-2.0 %{buildroot}/usr/share/license/%{name}
 
 %make_install
-
-%post
-/sbin/ldconfig
+###### for package signing step ######
 PKG_ID=hyCsE05ySM
-pkgcmd -q -i -t tpk -p /usr/apps/${PKG_ID}
+%define tizen_sign 1
+%define tizen_sign_base /usr/apps/${PKG_ID}
+%define tizen_sign_level platform
+%define tizen_author_sign 1
+%define tizen_dist_sign 1
 
-%postun
-/sbin/ldconfig
-PKG_ID=hyCsE05ySM
-pkgcmd -q -u -t tpk -n ${PKG_ID}
+%post
+/bin/rm -fr /opt/apps/hyCsE05ySM
+/usr/etc/package-manager/backend/tpk -i /usr/apps/hyCsE05ySM
 
 %files
+%manifest apps.CertificateSelector.manifest
 %defattr(-,root,root,-)
 /usr/share/license/%{name}
 /usr/apps/*