Refine the build configure
[platform/framework/native/certificate-selector.git] / packaging / apps.CertificateSelector.spec
index cfd44de..5a85ad7 100644 (file)
@@ -2,17 +2,22 @@ Name:                 apps.CertificateSelector
 Summary:               The app-control of the certificate manager
 Version:               1.2.2.0
 Release:               1
-Group:                 TO_BE/FILLED_IN
-License:               Apache License, Version 2.0
+Group:                 Application Framework
+Url:                   https://review.tizen.org/git/?p=platform/framework/native/certificate-selector.git;a=summary
+License:               Apache-2.0
 Source0:               %{name}-%{version}.tar.gz
+Source1001:            %{name}.manifest
 BuildRequires: cmake
 BuildRequires: pkgconfig(osp-appfw)
 BuildRequires: osp-appfw-internal-devel
 BuildRequires: pkgconfig(osp-uifw)
 BuildRequires:  hash-signer
 
+# smack domain requires
+Requires(post): osp-security-service
+
+# runtime requires
 Requires:              chromium
-Requires:              osp-security-service
 Requires:              pkgmgr
 
 %description
@@ -20,24 +25,33 @@ The app-control of the certificate manager
 
 %prep
 %setup -q
+cp %{SOURCE1001} .
 
 %build
 MAJORVER=`echo %{version} | awk 'BEGIN {FS="."}{print $1}'`
+
 %ifarch %{ix86}
-CXXFLAGS="$CXXFLAGS -D_OSP_DEBUG_ -D_OSP_X86_ -D_OSP_EMUL_" cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix}
+       ARCH=x86
+       CXXFLAGS="$CXXFLAGS -D_OSP_DEBUG_ -D_OSP_X86_"
+       %if 0%{?simulator}
+               CXXFLAGS="$CXXFLAGS -D_OSP_EMUL_"
+       %endif
 %else
-CXXFLAGS="-O2 -g -pipe -Wall -fno-exceptions -Wformat -Wformat-security -Wl,--as-needed -fmessage-length=0 -march=armv7-a -mtune=cortex-a8 -mlittle-endian -mfpu=neon -mfloat-abi=softfp -D__SOFTFP__ -mthumb -Wa,-mimplicit-it=thumb -funwind-tables -D_OSP_DEBUG_ -D_OSP_ARMEL_" cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix}
+       ARCH=arm
+       CXXFLAGS="-O2 -g -pipe -Wall -fno-exceptions -Wformat -Wformat-security -Wl,--as-needed -fmessage-length=0 -march=armv7-a -mtune=cortex-a8 -mlittle-endian -mfpu=neon -mfloat-abi=softfp -D__SOFTFP__ -mthumb -Wa,-mimplicit-it=thumb -funwind-tables -D_OSP_DEBUG_ -D_OSP_ARMEL_"
 %endif
 
-# Call make instruction with smp support
-make %{?jobs:-j%jobs}
+%if 0%{?tizen_build_binary_release_type_eng}
+       CXXFLAGS="$CXXFLAGS -D_SECURE_LOG"
+%endif
 
-%install
-rm -rf %{buildroot}
-mkdir -p %{buildroot}/usr/share/license
-cp %{_builddir}/%{name}-%{version}/LICENSE.Apache-2.0 %{buildroot}/usr/share/license/%{name}
+cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix}
 
+make %{?_smp_mflags}
+
+%install
 %make_install
+
 ###### for package signing step ######
 PKG_ID=hyCsE05ySM
 %define tizen_sign 1
@@ -51,6 +65,7 @@ PKG_ID=hyCsE05ySM
 /usr/etc/package-manager/backend/tpk -i /usr/apps/hyCsE05ySM
 
 %files
+%manifest %{name}.manifest
+%license LICENSE.Apache-2.0
 %defattr(-,root,root,-)
-/usr/share/license/%{name}
 /usr/apps/*