Fix for 46412
[apps/osp/Call.git] / packaging / apps.Call.spec
index 9f37ede..04fc356 100644 (file)
@@ -24,6 +24,7 @@ BuildRequires:  pkgconfig(contacts-service2)
 BuildRequires:  osp-appfw-internal-devel
 BuildRequires:  osp-uifw-internal-devel
 BuildRequires:  osp-media-internal-devel
+BuildRequires:  hash-signer
 
  # runtime requires
 Requires: osp-installer
@@ -48,10 +49,17 @@ make %{?jobs:-j%jobs}
 %install
 rm -rf %{buildroot}
 %make_install
+###### for package signing step ######
+PKG_ID=nI2PLNdTwi
+%define tizen_sign 1
+%define tizen_sign_base /usr/apps/${PKG_ID}
+%define tizen_sign_level platform
+%define tizen_author_sign 1
+%define tizen_dist_sign 1
 
 %post
 /sbin/ldconfig
-PKG_ID=zktdpemtmw
+PKG_ID=nI2PLNdTwi
 echo "/usr/etc/package-manager/backend/tpk -i /usr/apps/"${PKG_ID}
 /usr/etc/package-manager/backend/tpk -i /usr/apps/${PKG_ID}
 cp -f /usr/lib/osp/osp-ui-app-loader /usr/apps/${PKG_ID}/bin/Call
@@ -59,7 +67,7 @@ cp -f /usr/lib/osp/osp-ui-app-loader /usr/apps/${PKG_ID}/bin/Call
 
 %postun
 /sbin/ldconfig
-PKG_ID=zktdpemtmw
+PKG_ID=nI2PLNdTwi
 echo "/usr/etc/package-manager/backend/tpk -u "${PKG_ID}
 /usr/etc/package-manager/backend/tpk -u ${PKG_ID}