Release version 1.4.0
[platform/core/appfw/app-core.git] / packaging / app-core.spec
index ff0dfe8..8d0a2bf 100644 (file)
@@ -1,25 +1,14 @@
-%bcond_with x
-%bcond_with wayland
-
 Name:           app-core
 Summary:        Application basic
-Version:        1.2
+Version:        1.4.0
 Release:        0
 Group:          Application Framework/Libraries
 License:        Apache-2.0
 Source0:        app-core-%{version}.tar.gz
-%if %{with x}
-BuildRequires:  pkgconfig(x11)
-BuildRequires:  pkgconfig(ecore-x)
-BuildRequires:  pkgconfig(eina)
-%else
-%if %{with wayland}
 BuildRequires:  pkgconfig(ecore-wayland)
 BuildRequires:  pkgconfig(wayland-client)
 BuildRequires:  pkgconfig(tizen-extension-client)
 BuildRequires:  pkgconfig(wayland-tbm-client)
-%endif
-%endif
 Source1001:     app-core.manifest
 BuildRequires:  pkgconfig(gio-2.0)
 BuildRequires:  pkgconfig(sensor)
@@ -78,9 +67,6 @@ Requires:   pkgconfig(sensor)
 Requires:   pkgconfig(vconf)
 Requires:   pkgconfig(elementary)
 Requires:   pkgconfig(aul)
-%if %{with x}
-Requires:   pkgconfig(x11)
-%endif
 
 %description common-devel
 Application basics common (devel)
@@ -98,17 +84,8 @@ Application basics template
 cp %{SOURCE1001} .
 
 %build
-%if %{with wayland}
-_WITH_WAYLAND=ON
-%endif
-%if %{with x}
-_WITH_X11=ON
-%endif
-
 MAJORVER=`echo %{version} | awk 'BEGIN {FS="."}{print $1}'`
 %cmake . \
-       -D_WITH_WAYLAND:BOOL=${_WITH_WAYLAND} \
-       -D_WITH_X11:BOOL=${_WITH_X11} \
        -DENABLE_GTK=OFF \
        -DFULLVER=%{version} \
        -DMAJORVER=${MAJORVER}
@@ -138,6 +115,7 @@ rm -rf %{buildroot}
 %files efl-devel
 %manifest %{name}.manifest
 %{_includedir}/appcore/appcore-efl.h
+%{_includedir}/appcore/appcore_ui_base.h
 %{_libdir}/libappcore-efl.so
 %{_libdir}/pkgconfig/appcore-efl.pc
 
@@ -151,4 +129,5 @@ rm -rf %{buildroot}
 %{_libdir}/libappcore-common.so
 %{_libdir}/pkgconfig/appcore-common.pc
 %{_includedir}/appcore/appcore-common.h
-%{_includedir}/SLP_Appcore_PG.h
+%{_includedir}/appcore/appcore_base.h
+