Support Wayland and X11 profiles at the same time
[platform/core/appfw/app-core.git] / packaging / app-core.spec
index 6aac880..8c24e65 100644 (file)
@@ -1,30 +1,39 @@
-Name:       app-core
-Summary:    Application basic
-Version:    1.2
-Release:    44
-Group:      Application Framework
-License:    Apache License, Version 2.0
-Source0:    app-core-%{version}.tar.gz
-Source101:  packaging/core-efl.target
+%bcond_with x
+%bcond_with wayland
+
+Name:           app-core
+Summary:        Application basic
+Version:        1.2
+Release:        0
+Group:          Application Framework/Libraries
+License:        Apache-2.0
+Source0:        app-core-%{version}.tar.gz
+%if %{with wayland}
+Source101:      packaging/core-efl-wayland.target
+%else
+Source101:      packaging/core-efl-x.target
+%endif
+%if %{with x}
+BuildRequires:  pkgconfig(x11)
+BuildRequires:  pkgconfig(ecore-x)
+%endif
+Source1001:     app-core.manifest
 BuildRequires:  pkgconfig(sensor)
 BuildRequires:  pkgconfig(vconf)
 BuildRequires:  pkgconfig(aul)
 BuildRequires:  pkgconfig(rua)
 BuildRequires:  pkgconfig(dlog)
-BuildRequires:  pkgconfig(x11)
 BuildRequires:  pkgconfig(elementary)
 BuildRequires:  pkgconfig(ecore)
-BuildRequires:  pkgconfig(ecore-x)
 BuildRequires:  pkgconfig(gobject-2.0)
 BuildRequires:  pkgconfig(glib-2.0)
+BuildRequires:  pkgconfig(libtzplatform-config)
 BuildRequires:  cmake
 
-
 %description
 SLP common application basic
 
 
-
 %package efl
 Summary:    App basic EFL
 Group:      Development/Libraries
@@ -34,6 +43,7 @@ Requires(postun): /sbin/ldconfig
 %description efl
 Application basic EFL
 
+
 %package efl-devel
 Summary:    App basic EFL (devel)
 Group:      Development/Libraries
@@ -43,6 +53,7 @@ Requires:   %{name}-common-devel = %{version}-%{release}
 %description efl-devel
 Application basic EFL (devel)
 
+
 %package common
 Summary:    App basics common
 Group:      Development/Libraries
@@ -52,6 +63,7 @@ Requires(postun): /sbin/ldconfig
 %description common
 Application basics common
 
+
 %package common-devel
 Summary:    App basics common (devel)
 Group:      Development/Libraries
@@ -60,10 +72,14 @@ Requires:   pkgconfig(sensor)
 Requires:   pkgconfig(vconf)
 Requires:   pkgconfig(elementary)
 Requires:   pkgconfig(aul)
+%if %{with x}
+Requires:   pkgconfig(x11)
+%endif
 
 %description common-devel
 Application basics common (devel)
 
+
 %package template
 Summary:    App basics template
 Group:      Development/Libraries
@@ -74,54 +90,64 @@ Application basics template
 
 %prep
 %setup -q 
+cp %{SOURCE1001} .
+
 
 %build
-%cmake . -DENABLE_GTK=OFF
 
+%cmake . \
+%if %{with wayland}
+-Dwith_wayland=TRUE\
+%endif
+%if %{with x}
+-Dwith_x11=TRUE\
+%endif
+-DENABLE_GTK=OFF
 
 make %{?jobs:-j%jobs}
 
+
 %install
 rm -rf %{buildroot}
 %make_install
-install -d %{buildroot}%{_prefix}/lib/systemd/user/core-efl.target.wants
-install -m0644 %{SOURCE101} %{buildroot}%{_prefix}/lib/systemd/user/
+install -d %{buildroot}%{_unitdir_user}/core-efl.target.wants
+install -m0644 %{SOURCE101} %{buildroot}%{_unitdir_user}/core-efl.target
 
 
-%post efl -p /sbin/ldconfig
-
-%postun efl -p /sbin/ldconfig
-
-%post common -p /sbin/ldconfig
-
-%postun common -p /sbin/ldconfig
+%post -n app-core-efl -p /sbin/ldconfig
 
+%postun -n app-core-efl -p /sbin/ldconfig
 
+%post -n app-core-common -p /sbin/ldconfig
 
+%postun -n app-core-common -p /sbin/ldconfig
 
 
 %files efl
-%manifest app-core.manifest
+%manifest %{name}.manifest
 %defattr(-,root,root,-)
 %{_libdir}/libappcore-efl.so.*
+%license LICENSE
 
 %files efl-devel
+%manifest %{name}.manifest
 %defattr(-,root,root,-)
 %{_includedir}/appcore/appcore-efl.h
 %{_libdir}/libappcore-efl.so
 %{_libdir}/pkgconfig/appcore-efl.pc
 
 %files common
-%manifest app-core.manifest
+%manifest %{name}.manifest
 %defattr(-,root,root,-)
 %{_libdir}/libappcore-common.so.*
 %{_prefix}/lib/systemd/user/core-efl.target
 %{_prefix}/lib/systemd/user/core-efl.target.wants/
+%license LICENSE
 
 %files common-devel
+%manifest %{name}.manifest
 %defattr(-,root,root,-)
 %{_libdir}/libappcore-common.so
 %{_libdir}/pkgconfig/appcore-common.pc
 %{_includedir}/appcore/appcore-common.h
 %{_includedir}/SLP_Appcore_PG.h
-