Memory leak while creating duplicate bundle
[platform/core/appfw/app-core.git] / packaging / app-core.spec
index 7ad06d5..6fb3533 100644 (file)
@@ -3,7 +3,7 @@
 
 Name:           app-core
 Summary:        Application basic
-Version:        1.2
+Version:        1.3.0
 Release:        0
 Group:          Application Framework/Libraries
 License:        Apache-2.0
@@ -15,10 +15,13 @@ BuildRequires:  pkgconfig(eina)
 %else
 %if %{with wayland}
 BuildRequires:  pkgconfig(ecore-wayland)
+BuildRequires:  pkgconfig(wayland-client)
+BuildRequires:  pkgconfig(tizen-extension-client)
+BuildRequires:  pkgconfig(wayland-tbm-client)
 %endif
 %endif
 Source1001:     app-core.manifest
-BuildRequires:  pkgconfig(dbus-1)
+BuildRequires:  pkgconfig(gio-2.0)
 BuildRequires:  pkgconfig(sensor)
 BuildRequires:  pkgconfig(vconf)
 BuildRequires:  pkgconfig(aul)
@@ -28,9 +31,10 @@ BuildRequires:  pkgconfig(elementary)
 BuildRequires:  pkgconfig(ecore)
 BuildRequires:  pkgconfig(gobject-2.0)
 BuildRequires:  pkgconfig(glib-2.0)
-BuildRequires:  pkgconfig(libtzplatform-config)
 BuildRequires:  pkgconfig(pkgmgr-info)
+BuildRequires:  pkgconfig(ttrace)
 BuildRequires:  cmake
+BuildRequires:  pkgconfig(capi-system-info)
 
 %description
 SLP common application basic
@@ -89,22 +93,25 @@ Group:      Development/Libraries
 %description template
 Application basics template
 
-
 %prep
-%setup -q 
+%setup -q
 cp %{SOURCE1001} .
 
-
 %build
-
-%cmake . \
 %if %{with wayland}
--Dwith_wayland=TRUE\
+_WITH_WAYLAND=ON
 %endif
 %if %{with x}
--Dwith_x11=TRUE\
+_WITH_X11=ON
 %endif
--DENABLE_GTK=OFF
+
+MAJORVER=`echo %{version} | awk 'BEGIN {FS="."}{print $1}'`
+%cmake . \
+       -D_WITH_WAYLAND:BOOL=${_WITH_WAYLAND} \
+       -D_WITH_X11:BOOL=${_WITH_X11} \
+       -DENABLE_GTK=OFF \
+       -DFULLVER=%{version} \
+       -DMAJORVER=${MAJORVER}
 
 make %{?_smp_mflags}