Release version 1.4.5
[platform/core/appfw/app-core.git] / packaging / app-core.spec
index 9441160..1fcbeb2 100644 (file)
@@ -1,24 +1,16 @@
-%bcond_with x
-%bcond_with wayland
-
 Name:           app-core
 Summary:        Application basic
-Version:        1.2
+Version:        1.4.5
 Release:        0
 Group:          Application Framework/Libraries
 License:        Apache-2.0
 Source0:        app-core-%{version}.tar.gz
-%if %{with x}
-BuildRequires:  pkgconfig(x11)
-BuildRequires:  pkgconfig(ecore-x)
-BuildRequires:  pkgconfig(eina)
-%else
-%if %{with wayland}
 BuildRequires:  pkgconfig(ecore-wayland)
-%endif
-%endif
+BuildRequires:  pkgconfig(wayland-client)
+BuildRequires:  pkgconfig(tizen-extension-client)
+BuildRequires:  pkgconfig(wayland-tbm-client)
 Source1001:     app-core.manifest
-BuildRequires:  pkgconfig(dbus-glib-1)
+BuildRequires:  pkgconfig(gio-2.0)
 BuildRequires:  pkgconfig(sensor)
 BuildRequires:  pkgconfig(vconf)
 BuildRequires:  pkgconfig(aul)
@@ -28,9 +20,10 @@ BuildRequires:  pkgconfig(elementary)
 BuildRequires:  pkgconfig(ecore)
 BuildRequires:  pkgconfig(gobject-2.0)
 BuildRequires:  pkgconfig(glib-2.0)
-BuildRequires:  pkgconfig(libtzplatform-config)
 BuildRequires:  pkgconfig(pkgmgr-info)
+BuildRequires:  pkgconfig(ttrace)
 BuildRequires:  cmake
+BuildRequires:  pkgconfig(capi-system-info)
 
 %description
 SLP common application basic
@@ -74,9 +67,6 @@ Requires:   pkgconfig(sensor)
 Requires:   pkgconfig(vconf)
 Requires:   pkgconfig(elementary)
 Requires:   pkgconfig(aul)
-%if %{with x}
-Requires:   pkgconfig(x11)
-%endif
 
 %description common-devel
 Application basics common (devel)
@@ -89,38 +79,16 @@ Group:      Development/Libraries
 %description template
 Application basics template
 
-%if "%{?tizen_profile_name}" == "wearable"
-%define appfw_feature_background_management 1
-%else
-%if "%{?tizen_profile_name}" == "mobile"
-%define appfw_feature_background_management 1
-%else
-%if "%{?tizen_profile_name}" == "tv"
-%define appfw_feature_background_management 0
-%endif
-%endif
-%endif
-
 %prep
 %setup -q
 cp %{SOURCE1001} .
 
 %build
-%if %{with wayland}
-_WITH_WAYLAND=ON
-%endif
-%if %{with x}
-_WITH_X11=ON
-%endif
-%if 0%{?appfw_feature_background_management}
-_APPFW_FEATURE_BACKGROUND_MANAGEMENT=ON
-%endif
-
+MAJORVER=`echo %{version} | awk 'BEGIN {FS="."}{print $1}'`
 %cmake . \
-       -D_WITH_WAYLAND:BOOL=${_WITH_WAYLAND} \
-       -D_WITH_X11:BOOL=${_WITH_X11} \
-       -D_APPFW_FEATURE_BACKGROUND_MANAGEMENT:BOOL=${_APPFW_FEATURE_BACKGROUND_MANAGEMENT} \
-       -DENABLE_GTK=OFF
+       -DENABLE_GTK=OFF \
+       -DFULLVER=%{version} \
+       -DMAJORVER=${MAJORVER}
 
 make %{?_smp_mflags}
 
@@ -147,6 +115,7 @@ rm -rf %{buildroot}
 %files efl-devel
 %manifest %{name}.manifest
 %{_includedir}/appcore/appcore-efl.h
+%{_includedir}/appcore/appcore_ui_base.h
 %{_libdir}/libappcore-efl.so
 %{_libdir}/pkgconfig/appcore-efl.pc
 
@@ -160,4 +129,5 @@ rm -rf %{buildroot}
 %{_libdir}/libappcore-common.so
 %{_libdir}/pkgconfig/appcore-common.pc
 %{_includedir}/appcore/appcore-common.h
-%{_includedir}/SLP_Appcore_PG.h
+%{_includedir}/appcore/appcore_base.h
+