resetting manifest requested domain to floor
[platform/upstream/acl.git] / packaging / acl.spec
index 3bc2199..ea7a61f 100644 (file)
@@ -1,13 +1,15 @@
-Name:           acl
 %define lname  libacl
+
+Name:           acl
 BuildRequires:  libattr-devel
 Summary:        Commands for Manipulating POSIX Access Control Lists
 License:        GPL-2.0+ ; LGPL-2.1+
-Group:          System/Filesystems
+Group:          Security/Access Control
 Version:        2.2.51
 Release:        0
 Source:         %name-%version.src.tar.gz
 Source2:        baselibs.conf
+Source1001:    acl.manifest
 Url:            http://download.savannah.gnu.org/releases-noredirect/acl/
 
 %description
@@ -16,7 +18,7 @@ control lists.
 
 %package -n %lname
 Summary:        A dynamic library for accessing POSIX Access Control Lists
-Group:          System/Libraries
+Group:          Security/Access Control
 
 %description -n %lname
 This package contains the libacl.so dynamic library which contains the
@@ -25,7 +27,7 @@ control lists.
 
 %package -n libacl-devel
 Summary:        Include Files and Libraries mandatory for Development
-Group:          Development/Libraries/C and C++
+Group:          Development/Libraries
 Requires:       %lname = %version
 Requires:       glibc-devel
 # the .so file references libattr.so.x, so require libattr-devel
@@ -37,6 +39,7 @@ to develop applications that require these.
 
 %prep
 %setup -q -n acl-%version
+cp %{SOURCE1001} .
 
 %build
 export OPTIMIZER="$RPM_OPT_FLAGS -fPIC"
@@ -72,7 +75,9 @@ rm -f %{buildroot}/%{_libdir}/*.{a,la}
 %docs_package
 
 %files 
+%manifest %{name}.manifest
 %defattr(-,root,root)
+%license doc/COPYING doc/COPYING.LGPL
 %attr(755,root,root) %{_bindir}/chacl
 %attr(755,root,root) %{_bindir}/getfacl
 %attr(755,root,root) %{_bindir}/setfacl
@@ -84,6 +89,7 @@ rm -f %{buildroot}/%{_libdir}/*.{a,la}
 %doc %attr(644,root,root) /usr/share/doc/packages/acl/README
 
 %files -n libacl-devel
+%manifest %{name}.manifest
 %defattr(-,root,root)
 %dir %attr(755,root,root) %{_includedir}/acl
 %attr(644,root,root) %{_includedir}/acl/libacl.h
@@ -91,6 +97,7 @@ rm -f %{buildroot}/%{_libdir}/*.{a,la}
 %attr(755,root,root) %{_libdir}/libacl.so
 
 %files -n %lname
+%manifest %{name}.manifest
 %defattr(755,root,root,755)
 %{_libdir}/libacl.so.1*