change license from "GPL-2.0+ and LGPL-2.1+" to "LGPL-2.1+ and GPL-2.0+" in spec...
[platform/upstream/acl.git] / packaging / acl.spec
index 07e8b1a..0db6030 100644 (file)
@@ -1,13 +1,15 @@
-Name:           acl
 %define lname  libacl
+
+Name:           acl
 BuildRequires:  libattr-devel
 Summary:        Commands for Manipulating POSIX Access Control Lists
-License:        GPL-2.0+ ; LGPL-2.1+
-Group:          System/Filesystems
-Version:        2.2.51
+License:        LGPL-2.1+ and GPL-2.0+
+Group:          Security/Access Control
+Version:        2.2.52
 Release:        0
 Source:         %name-%version.src.tar.gz
 Source2:        baselibs.conf
+Source1001:    acl.manifest
 Url:            http://download.savannah.gnu.org/releases-noredirect/acl/
 
 %description
@@ -16,7 +18,7 @@ control lists.
 
 %package -n %lname
 Summary:        A dynamic library for accessing POSIX Access Control Lists
-Group:          System/Libraries
+Group:          Security/Access Control
 
 %description -n %lname
 This package contains the libacl.so dynamic library which contains the
@@ -25,7 +27,7 @@ control lists.
 
 %package -n libacl-devel
 Summary:        Include Files and Libraries mandatory for Development
-Group:          Development/Libraries/C and C++
+Group:          Development/Libraries
 Requires:       %lname = %version
 Requires:       glibc-devel
 # the .so file references libattr.so.x, so require libattr-devel
@@ -37,6 +39,7 @@ to develop applications that require these.
 
 %prep
 %setup -q -n acl-%version
+cp %{SOURCE1001} .
 
 %build
 export OPTIMIZER="$RPM_OPT_FLAGS -fPIC"
@@ -45,9 +48,8 @@ CFLAGS="$RPM_OPT_FLAGS"
 %configure \
        --prefix=/ \
        --exec-prefix=/ \
-       --sbindir=/bin \
-       --libdir=/%{_lib} \
-       --libexecdir=/%{_lib} \
+       --libdir=%{_libdir} \
+       --libexecdir=%{_libdir} \
        --enable-gettext=no \
        --disable-static \
        --with-pic
@@ -62,9 +64,10 @@ export DIST_ROOT DIST_INSTALL DIST_INSTALL_DEV DIST_INSTALL_LIB
 /usr/bin/make install DIST_MANIFEST="$DIST_INSTALL"
 /usr/bin/make install-dev DIST_MANIFEST="$DIST_INSTALL_DEV"
 /usr/bin/make install-lib DIST_MANIFEST="$DIST_INSTALL_LIB"
-%{__mkdir_p} %{buildroot}%{_libdir}
-%{__ln_s} -v /%{_lib}/$(readlink %{buildroot}/%{_lib}/lib%{name}.so) %{buildroot}%{_libdir}/lib%{name}.so
-%{__rm} -v %{buildroot}/%{_lib}/lib%{name}.{la,so}
+
+rm %{buildroot}%{_defaultdocdir}/%{name}/COPYING*
+
+rm -f %{buildroot}/%{_libdir}/*.{a,la}
 
 %post -n %lname -p /sbin/ldconfig
 
@@ -74,18 +77,19 @@ export DIST_ROOT DIST_INSTALL DIST_INSTALL_DEV DIST_INSTALL_LIB
 %docs_package
 
 %files 
+%manifest %{name}.manifest
 %defattr(-,root,root)
+%license doc/COPYING doc/COPYING.LGPL
 %attr(755,root,root) %{_bindir}/chacl
 %attr(755,root,root) %{_bindir}/getfacl
 %attr(755,root,root) %{_bindir}/setfacl
 %dir %attr(755,root,root) /usr/share/doc/packages/acl
 %doc %attr(644,root,root) /usr/share/doc/packages/acl/CHANGES.gz
-%doc %attr(644,root,root) /usr/share/doc/packages/acl/COPYING
-%doc %attr(644,root,root) /usr/share/doc/packages/acl/COPYING.LGPL
 %doc %attr(644,root,root) /usr/share/doc/packages/acl/PORTING
 %doc %attr(644,root,root) /usr/share/doc/packages/acl/README
 
 %files -n libacl-devel
+%manifest %{name}.manifest
 %defattr(-,root,root)
 %dir %attr(755,root,root) %{_includedir}/acl
 %attr(644,root,root) %{_includedir}/acl/libacl.h
@@ -93,6 +97,7 @@ export DIST_ROOT DIST_INSTALL DIST_INSTALL_DEV DIST_INSTALL_LIB
 %attr(755,root,root) %{_libdir}/libacl.so
 
 %files -n %lname
+%manifest %{name}.manifest
 %defattr(755,root,root,755)
-/%{_lib}/libacl.so.1*
+%{_libdir}/libacl.so.1*