Elementary migration revision 69832
[framework/uifw/elementary.git] / debian / rules
index 0b7c31b..5d1c41c 100755 (executable)
@@ -5,10 +5,11 @@ include /usr/share/cdbs/1/class/autotools.mk
 
 DEB_CONFIGURE_SCRIPT := ./autogen.sh
 DEB_MAKE_CLEAN_TARGET := distclean
-DEB_CONFIGURE_EXTRA_FLAGS := 
+DEB_CONFIGURE_EXTRA_FLAGS := --enable-dependency-tracking --disable-doc --disable-web
+DEB_MAKE_EXTRA_ARGS := V=0
 
-CFLAGS += -fPIC -W -Wall -Wextra
+CFLAGS += -fPIC -Wall
 LDFLAGS += -Wl,--hash-style=both -Wl,--as-needed
 
 clean::
-       [ ! -f Makefile ] || make distclean
+       [ ! -f Makefile ] || make distclean || true