Initial packaging
[tools/yum-metadata-parser.git] / yum-metadata-parser.spec
1 %{!?python_sitelib_platform: %define python_sitelib_platform %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
2
3 Summary: A fast metadata parser for yum
4 Name: yum-metadata-parser
5 Version: 1.1.4
6 Release: 1
7 Source0: %{name}-%{version}.tar.gz
8 License: GPL
9 Group: Development/Libraries
10 URL: http://devel.linux.duke.edu/cgi-bin/viewcvs.cgi/yum-metadata-parser/
11 Requires: yum >= 2.6.2
12 BuildRequires: python-devel
13 BuildRequires: glib2-devel
14 BuildRequires: libxml2-devel
15 BuildRequires: sqlite-devel
16 BuildRequires: pkgconfig
17 BuildRoot:  %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
18
19 %description
20 Fast metadata parser for yum implemented in C.
21
22 %prep
23 %setup
24
25 %build
26 %{__python} setup.py build
27
28 %install
29 %{__python} setup.py install -O1 --root=%{buildroot}
30
31 %clean
32 %{__rm} -rf %{buildroot}
33
34 %files
35 %defattr(-,root,root)
36 %doc README AUTHORS ChangeLog
37 %{python_sitelib_platform}/_sqlitecache.so
38 %{python_sitelib_platform}/sqlitecachec.py
39 %{python_sitelib_platform}/sqlitecachec.pyc
40 %{python_sitelib_platform}/sqlitecachec.pyo
41 %{python_sitelib_platform}/*egg-info
42
43
44 %changelog
45 * Thu Jan  7 2010 Seth Vidal <skvidal at fedoraproject.org>
46 - 1.1.4 b/c I made a mistake
47
48 * Thu Jan  7 2010 Seth Vidal <skvidal at fedoraproject.org>
49 - add the egginfo support for python 2.5 and above
50
51 * Thu Jan  7 2010 Seth Vidal <skvidal at fedoraproject.org> 
52 - bump the version number for an official release
53
54 * Wed Aug 29 2007 Seth Vidal <skvidal at fedoraproject.org>
55 - remove the %{dist} which doesn't really belong in the upstream pkg
56
57 * Fri Aug 24 2007 Seth Vidal <skvidal at fedoraproject.org>
58 - 1.1.2
59
60 * Wed May 16 2007 Paul Nasrat <pnasrat at redhat.com>
61 - Expose DBVERSION
62
63 * Fri Apr 27 2007 Seth Vidal <skvidal at linux.duke.edu>
64 - split out 1.1.0 for dbversion 10
65
66 * Wed Apr  4 2007 Seth Vidal <skvidal at linux.duke.edu>
67 - 1.0.4
68
69 * Sun Jan  7 2007 Seth Vidal <skvidal at linux.duke.edu>
70 - 1.0.3
71
72 * Wed Jul 12 2006 Seth Vidal <skvidal at linux.duke.edu>
73 - 1.0.2
74
75 * Mon Jun 19 2006 Seth Vidal <skvidal at linux.duke.edu>
76 - 1.0.1
77
78 * Mon Jun 05 2006 Tambet Ingo <tambet@ximian.com> - 1.0-3
79 - Require yum >= 2.6.2
80
81 * Sat Jun 04 2006 Terje Rosten <terje.rosten@pvv.org> - 1.0-2
82 - add buildrequires
83 - doc files
84 - url
85
86 * Fri Jun 02 2006 Terje Rosten <terje.rosten@pvv.org> - 1.0-0.1
87 - initial package
88