upgrade rpm version to 4.14.1
[platform/upstream/rpm.git] / tests / data / SPECS / test-subpackages-pathpostfixes.spec
1 Name:           test
2 Version:        1.0
3 Release:        1
4 Summary:        Test
5
6 License:        Public Domain
7 URL:            https://fedoraproject.org
8 Source:         hello.c
9
10 %description
11 %{summary}.
12
13 %package test2
14 RemovePathPostfixes: .foobar
15 Summary: Test2.
16 %description test2
17
18 %prep
19 %autosetup -c -D -T
20 cp -a %{S:0} .
21
22 %build
23 gcc -g hello.c -o hello
24 cp hello.c hello2.c
25 gcc -g hello2.c -o hello.foobar
26
27 %install
28 mkdir -p %{buildroot}/bin
29 install -D -p -m 0755 -t %{buildroot}/bin hello
30 # Install as hello.foobar, but we want the postfix removed in the package...
31 install -D -p -m 0755 -t %{buildroot}/bin hello.foobar
32
33 %files
34 /bin/hello
35
36 %files test2
37 /bin/hello.foobar
38
39 %changelog