upgrade rpm version to 4.14.1
[platform/upstream/rpm.git] / tests / data / SPECS / test-subpackages-exclude.spec
1 Name:           test
2 Version:        1.0
3 Release:        1
4 Summary:        Test
5
6 License:        Public Domain
7 URL:            https://fedoraproject.org
8 Source:         hello.c
9
10 %description
11 %{summary}.
12
13 %package test2
14 Summary: Test2.
15 %description test2
16
17 %prep
18 %autosetup -c -D -T
19 cp -a %{S:0} .
20
21 %build
22 gcc -g hello.c -o hello
23 cp hello.c hello2.c
24 gcc -g hello2.c -o hello2
25 cp hello.c hello3.c
26 gcc -g hello3.c -o hello3
27
28 %install
29 mkdir -p %{buildroot}/bin
30 install -D -p -m 0755 -t %{buildroot}/bin hello
31 install -D -p -m 0755 -t %{buildroot}/bin hello2
32 # Install it, but then exclude it...
33 install -D -p -m 0755 -t %{buildroot}/bin hello3
34
35 %files
36 /bin/hello
37
38 %files test2
39 /bin/hello2
40 %exclude /bin/hello3
41
42 %changelog