Imported Upstream version 4.14.1
[platform/upstream/rpm.git] / tests / data / SPECS / prefixtest.spec
1 Name:           prefixtest
2 Version:        1.0
3 Release:        1
4 Summary:        Testing file glob behavior
5 Group:          Testing
6 License:        GPL
7 BuildArch:      noarch
8 RemovePathPostfixes: g:f
9
10 %description
11 %{summary}
12
13 %define testdir /opt/%{name}
14
15 %install
16 rm -rf $RPM_BUILD_ROOT
17
18 mkdir -p $RPM_BUILD_ROOT/%{testdir}
19 echo "foo" > $RPM_BUILD_ROOT/%{testdir}/weird%%name
20 for f in bif baf zab zeb zib; do
21     echo "$f" > $RPM_BUILD_ROOT/%{testdir}/$f
22 done
23 for f in bing bang bong; do
24     mkdir -p $RPM_BUILD_ROOT/%{testdir}/$f
25 done
26 mkdir -p $RPM_BUILD_ROOT/%{testdir}/foo
27 for f in one two three; do
28     echo "$f" > $RPM_BUILD_ROOT/%{testdir}/foo/$f
29 done
30
31 ln -s %{testdir}/zab $RPM_BUILD_ROOT/%{testdir}/linkgood
32 ln -s %{testdir}/zub $RPM_BUILD_ROOT/%{testdir}/linkbad
33
34 %files
35 %defattr(-,root,root,-)
36 %{testdir}/b??
37 %{testdir}/weird?name
38 %{testdir}/z*
39 %{testdir}/l*
40 %{testdir}/b*g/
41 %dir %{testdir}/foo
42 %{testdir}/foo/*