7c22d29aeacef3582b871cf7cb7b8b97bfc22f7a
[platform/upstream/rpm.git] / tests / data / SPECS / hlinktest.spec
1 Summary:          Testing hard link behavior
2 Name:             hlinktest
3 Version:          1.0
4 Release:          1
5 License:          Testing
6 Group:            Testing
7 BuildArch:        noarch
8 %description
9   
10 %install
11 rm -rf %{buildroot}
12 mkdir -p $RPM_BUILD_ROOT/foo
13 cat << EOF >> $RPM_BUILD_ROOT/foo/hello
14 #!/bin/sh
15 echo $0
16 EOF
17
18 cd $RPM_BUILD_ROOT/foo
19 cat hello > copyllo
20 chmod a+x hello copyllo
21 for f in foo bar world; do
22     ln hello hello-${f}
23 done
24
25 %files
26 %defattr(-,root,root)
27 /foo/*