Imported Upstream version 4.14.1
[platform/upstream/rpm.git] / tests / data / SPECS / hello2ln.spec
1 Summary: hello2 -- double hello, world rpm
2 Name: hello2
3 Version: 1.0
4 Release: 1
5 Group: Utilities
6 License: GPL
7 Distribution: RPM test suite.
8 Vendor: Red Hat Software
9 Packager: Red Hat Software <bugs@redhat.com>
10 URL: http://www.redhat.com
11 Source0: hello-1.0.tar.gz
12 Patch0: hello-1.0-modernize.patch
13 Excludearch: lsi
14 Excludeos: cpm
15 Provides: hi
16 Conflicts: goodbye
17 Obsoletes: howdy
18 Prefix: /usr
19
20 %description
21 Simple rpm demonstration.
22
23 %prep
24 %setup -q -n hello-1.0
25 %patch0 -p1 -b .modernize
26
27 %build
28 make CFLAGS="-g -O1"
29
30 %install
31 rm -rf $RPM_BUILD_ROOT
32 mkdir -p $RPM_BUILD_ROOT/usr/local/bin
33 make DESTDIR=$RPM_BUILD_ROOT install
34 ln $RPM_BUILD_ROOT/usr/local/bin/hello $RPM_BUILD_ROOT/usr/local/bin/hello2
35
36 %clean
37 rm -rf $RPM_BUILD_ROOT
38
39 %pre
40
41 %post
42
43 %preun
44
45 %postun
46
47 %files
48 %defattr(-,root,root)
49 %doc    FAQ
50 #%readme README
51 #%license COPYING
52 %attr(0751,root,root)   /usr/local/bin/hello
53 %attr(0751,root,root)   /usr/local/bin/hello2
54
55 %changelog
56 * Mon Jun  6 2016 Mark Wielaard <mjw@redhat.com>
57 - Hard link hello to hello2 for duplicate build-id testing.
58
59 * Wed May 18 2016 Mark Wielaard <mjw@redhat.com>
60 - Add hello2 for dwz testing support.
61
62 * Tue Oct 20 1998 Jeff Johnson <jbj@redhat.com>
63 - create.