43173602442087c9c9bd7c1912aa15077d31f1c9
[platform/upstream/SDL.git] / test / packaging / sdl_test.spec
1 Name:       org.tizen.sdl2_test
2 Summary:    sdl2demo
3 Version:    0.1
4 Release:    1
5 Group:      TO_BE/FILLED_IN
6 License:    Apache
7 Source0:    %{name}-%{version}.tar.gz
8
9 BuildRequires:  edje-bin
10 BuildRequires:  pkgconfig(dlog)
11
12 BuildRequires:  cmake
13 BuildRequires:  edje-bin
14 BuildRequires:  embryo-bin
15 BuildRequires:  gettext-devel
16
17 BuildRequires:  pkgconfig(egl)
18 BuildRequires:  pkgconfig(glesv2)
19 BuildRequires:  pkgconfig(glesv1)
20 BuildRequires:  pkgconfig(sdl2)
21
22 %define _packagedir /opt/usr/apps/%{name}
23 %define _resdir %{_packagedir}/res
24
25
26
27 Autoreq: no
28
29
30 %description
31 Description: sdl_test
32
33 %package devel
34 Summary:    sdl_test library development headers
35 Group:      Development/Libraries
36 Requires:   %{name} = %{version}
37
38 %description devel
39 Web App Service library development headers
40 %prep
41 %setup -q
42
43 %build
44 export CFLAGS="$CFLAGS %{?__vd_cflags}  -Wno-error"
45 export CXXFLAGS="$CXXFLAGS %{?__vd_cxxflags} -Wno-error"
46 cmake . \
47         -DCMAKE_INSTALL_PREFIX=%{_packagedir} \
48         -DPACKAGE_NAME=%{name} \
49         -DVERSION=%{version} \
50         -DTIZEN_VERSION=%{tizen}
51 #make %{?jobs:-j%jobs}
52 #output different color when make error
53 make 2>&1 %{?jobs:-j%jobs} | sed -e 's%^.*: error: .*$%\x1b[37;41m&\x1b[m%' -e  's%^.*: warning: .*$%\x1b[30;43m&\x1b[m%'
54
55 %install
56 rm -rf %{buildroot}
57
58 %make_install
59
60
61 %clean
62 rm -rf %{buildroot}
63
64 %post
65
66 %files
67 %defattr(-,root,root,-)
68 %attr(755,root,root) %{_packagedir}/*
69
70
71 %files devel