sys-apps/lthor: Initial version
[tools/muxpi-overlay.git] / sys-apps / lthor / lthor-9999.ebuild
1 # Copyright (c) 2018 Samsung Electronics Co., Ltd All Rights Reserved
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 if [[ ${PV} == "9999" ]]; then
7         EGIT_REPO_URI="git://git.tizen.org/tools/lthor"
8         inherit git-r3
9 else
10         SRC_URI="http://download.tizen.org/muxpi/releases/${P}.tar.gz"
11         KEYWORDS="~arm"
12 fi
13
14 inherit cmake-utils
15
16 DESCRIPTION="Phone flashing tool"
17 HOMEPAGE="https://source.tizen.org/documentation/reference/flash-device"
18
19 LICENSE="Apache-2.0"
20 SLOT="0"
21 IUSE=""
22
23 DEPEND="app-arch/libarchive:0/13[bzip2,lzma,zlib]
24         virtual/libusb:1"
25 RDEPEND="${DEPEND}"
26
27 pkg_postinst() {
28         udevadm --reload-rules
29 }