53ae8129e931a99c190934a6540222c037ebedcd
[platform/framework/web/crosswalk.git] / src / xwalk / packaging / crosswalk.spec
1 %bcond_with x
2 %bcond_with wayland
3
4 %ifarch x86_64 %{arm}
5 ### x86_64
6 # NaCl build on 64bit system require libc 32bit to build the 32 IRT.
7 # While Tizen 64bit image does not offer 32bit packages at all,
8 # check https://bugs.tizen.org/jira/browse/PTREL-803 for details.
9 # So disable nacl for 64bit now.
10 ### ARM
11 # Due to OBS build for ARM some files needed by NaCl to be build
12 # are not present.
13 %define _disable_nacl 1
14 %else
15 %define _disable_nacl 0
16 %endif
17
18 Name:           crosswalk
19 Version:        10.38.220.0
20 Release:        0
21 Summary:        Chromium-based app runtime
22 License:        (BSD-3-Clause and LGPL-2.1+)
23 Group:          Web Framework/Web Run Time
24 Url:            https://github.com/otcshare/crosswalk
25 Source:         %{name}.tar
26 Source1:        xwalk.in
27 Source2:        org.crosswalkproject.Runtime1.service
28 Source3:        xwalk.service.in
29 Source1001:     crosswalk.manifest
30 Source1002:     %{name}.xml.in
31 Source1003:     %{name}.png
32 Patch9:         Blink-Add-GCC-flag-Wno-narrowing-fix-64bits-build.patch
33 Patch10:        crosswalk-do-not-look-for-gtk-dependencies-on-x11.patch
34
35 BuildRequires:  bison
36 BuildRequires:  bzip2-devel
37 BuildRequires:  elfutils
38 BuildRequires:  expat-devel
39 BuildRequires:  flex
40 BuildRequires:  gperf
41 BuildRequires:  libcap-devel
42 BuildRequires:  libelf-devel
43 BuildRequires:  ninja
44 BuildRequires:  python
45 BuildRequires:  python-xml
46 BuildRequires:  perl
47 BuildRequires:  which
48 BuildRequires:  pkgconfig(ail)
49 BuildRequires:  pkgconfig(alsa)
50 BuildRequires:  pkgconfig(appcore-common)
51 BuildRequires:  pkgconfig(cairo)
52 BuildRequires:  pkgconfig(capi-location-manager)
53 BuildRequires:  pkgconfig(dbus-1)
54 BuildRequires:  pkgconfig(fontconfig)
55 BuildRequires:  pkgconfig(freetype2)
56 BuildRequires:  pkgconfig(gles20)
57 BuildRequires:  pkgconfig(glib-2.0)
58 BuildRequires:  pkgconfig(haptic)
59 BuildRequires:  pkgconfig(icu-i18n)
60 BuildRequires:  pkgconfig(libdrm)
61 BuildRequires:  pkgconfig(libexif)
62 BuildRequires:  pkgconfig(libpci)
63 BuildRequires:  pkgconfig(libpulse)
64 BuildRequires:  pkgconfig(libtzplatform-config)
65 BuildRequires:  pkgconfig(libudev)
66 BuildRequires:  pkgconfig(libxml-2.0)
67 BuildRequires:  pkgconfig(libxslt)
68 BuildRequires:  pkgconfig(pango)
69 BuildRequires:  pkgconfig(pkgmgr)
70 BuildRequires:  pkgconfig(pkgmgr-info)
71 BuildRequires:  pkgconfig(pkgmgr-installer)
72 BuildRequires:  pkgconfig(pkgmgr-parser)
73 BuildRequires:  pkgconfig(secure-storage)
74 BuildRequires:  pkgconfig(sensor)
75 BuildRequires:  pkgconfig(nspr)
76 BuildRequires:  pkgconfig(nss)
77 BuildRequires:  pkgconfig(vconf)
78 BuildRequires:  pkgconfig(xmlsec1)
79 %if %{with x}
80 BuildRequires:  pkgconfig(x11)
81 BuildRequires:  pkgconfig(xcomposite)
82 BuildRequires:  pkgconfig(xcursor)
83 BuildRequires:  pkgconfig(xdamage)
84 BuildRequires:  pkgconfig(xext)
85 BuildRequires:  pkgconfig(xfixes)
86 BuildRequires:  pkgconfig(xi)
87 BuildRequires:  pkgconfig(xrandr)
88 BuildRequires:  pkgconfig(xrender)
89 BuildRequires:  pkgconfig(xscrnsaver)
90 BuildRequires:  pkgconfig(xt)
91 BuildRequires:  pkgconfig(xtst)
92 %endif
93
94 %if "%{profile}" == "ivi"
95 BuildRequires:  pkgconfig(murphy-common)
96 BuildRequires:  pkgconfig(murphy-resource)
97 %endif
98
99 %if %{with wayland}
100 BuildRequires:  pkgconfig(wayland-client)
101 BuildRequires:  pkgconfig(wayland-cursor)
102 BuildRequires:  pkgconfig(wayland-egl)
103 BuildRequires:  pkgconfig(xkbcommon)
104 %else
105 BuildRequires:  pkgconfig(scim)
106 %endif
107 Requires:  ca-certificates-tizen
108
109 %description
110 Crosswalk is an app runtime based on Chromium. It is an open source project started by the Intel Open Source Technology Center (http://www.01.org).
111
112 %define _manifestdir %TZ_SYS_RO_PACKAGES
113 %define _manifestdir_ro %TZ_SYS_RO_PACKAGE
114 %define _desktop_icondir %TZ_SYS_RW_ICONS/default/small
115 %define _desktop_icondir_ro %TZ_SYS_RO_ICONS/default/small
116 %define _dbusservicedir /usr/share/dbus-1/services
117 %define _systemduserservicedir /usr/lib/systemd/user
118
119 %prep
120 %setup -q -n crosswalk
121
122 cp %{SOURCE1} .
123 cp %{SOURCE3} .
124 cp %{SOURCE1001} .
125 cp %{SOURCE1002} .
126 cp %{SOURCE1003} .
127 sed "s/@VERSION@/%{version}/g" %{name}.xml.in > %{name}.xml
128 sed "s|@LIB_INSTALL_DIR@|%{_libdir}|g" xwalk.in > xwalk
129 sed "s|@LIB_INSTALL_DIR@|%{_libdir}|g" xwalk.service.in > xwalk.service
130
131 cp -a src/AUTHORS AUTHORS.chromium
132 cp -a src/LICENSE LICENSE.chromium
133 cp -a src/xwalk/LICENSE LICENSE.xwalk
134
135 %patch9
136
137 # The profiles using Wayland (and thus Ozone) do not need this patch.
138 %if !%{with wayland}
139 %patch10
140 %endif
141
142 %build
143
144 # Stop unconditionally passing -Wall to the compiler. Chromium has its own
145 # mechanisms for deciding which parts of the code need -Wall and which need it
146 # to be left out (since several pieces are built with -Werror). At least in
147 # M39, this is preventing the "rtc_base" target from being built because it
148 # does not expect -Wall to be passed to the compiler (see webrtc issue 3307).
149 export CXXFLAGS=`echo $CXXFLAGS | sed s,-Wall,,g`
150
151 # For ffmpeg on ia32. The original CFLAGS set by the gyp and config files in
152 # src/third_party/ffmpeg already pass -O2 -fomit-frame-pointer, but Tizen's
153 # CFLAGS end up appending -fno-omit-frame-pointer. See http://crbug.com/37246
154 export CFLAGS=`echo $CFLAGS | sed s,-fno-omit-frame-pointer,,g`
155
156 %if ! %{_disable_nacl}
157 # For nacl_bootstrap on ia32. The original CFLAGS set by the gyp
158 # native_client/src/trusted/service_runtime/linux/nacl_bootstrap.gyp already ignored 
159 # -fstack-protector and -funwind-tables, but Tizen's CFLAGS end up appending them, thus
160 # causing linking failures. Check XWALK-1689 for details.
161 export CFLAGS=`echo $CFLAGS | sed s,-fstack-protector,,g`
162 export CFLAGS=`echo $CFLAGS | sed s,-funwind-tables,,g`
163 %endif
164
165 # Building the RPM in the GBS chroot fails with errors such as
166 #   /usr/lib/gcc/i586-tizen-linux/4.7/../../../../i586-tizen-linux/bin/ld:
167 #       failed to set dynamic section sizes: Memory exhausted
168 # For now, work around it by passing a GNU ld-specific flag that optimizes the
169 # linker for memory usage.
170 export LDFLAGS="${LDFLAGS} -Wl,--no-keep-memory"
171
172 # Support building in a non-standard directory, possibly outside %{_builddir}.
173 # Since the build root is erased every time a new build is performed, one way
174 # to avoid losing the build directory is to specify a location outside the
175 # build root to the BUILDDIR_NAME definition, such as "/var/tmp/xwalk-build"
176 # (remember all paths are still inside the chroot):
177 #    gbs build --define 'BUILDDIR_NAME /some/path'
178 BUILDDIR_NAME="%{?BUILDDIR_NAME}"
179 if [ -n "${BUILDDIR_NAME}" ]; then
180    mkdir -p "${BUILDDIR_NAME}"
181    ln -s "${BUILDDIR_NAME}" src/out
182 fi
183
184 %if %{with wayland}
185 GYP_EXTRA_FLAGS="${GYP_EXTRA_FLAGS} -Duse_ozone=1 -Denable_ozone_wayland_vkb=1 -Denable_xdg_shell=1"
186 %endif
187
188 GYP_EXTRA_FLAGS="${GYP_EXTRA_FLAGS} -Ddisable_nacl=%{_disable_nacl}"
189
190 # Linking fails in Tizen Common when fatal ld warnings are enabled. XWALK-1379.
191 %if "%{profile}" == "common" || "%{profile}" == "generic"
192 GYP_EXTRA_FLAGS="${GYP_EXTRA_FLAGS} -Ddisable_fatal_linker_warnings=1"
193 %endif
194
195 # For building for arm in OBS, we need :
196 # -> to unset sysroot value.
197 # sysroot variable is automatically set for cross compilation to use arm-sysroot provided by Chromium project
198 # -> to force system ld binary.
199 # Indeed the build is made on Emulated / Virtualized environment that correspond
200 # to the target.
201 # gold ld used is avaible only for 32/64 bits Intel Arch.
202 # sysroot usage is not needed, we need to use arm libraries from the virtualized environment.
203 #
204 # Crosswalk build fails if the fpu selected in the gcc option is different from neon in case of arm7 compilation
205 # So force it.
206 %ifarch %{arm}
207 GYP_EXTRA_FLAGS="${GYP_EXTRA_FLAGS} -Dsysroot= -Dlinux_use_gold_binary=0"
208 export CFLAGS=`echo $CFLAGS | sed s,-mfpu=vfpv3,-mfpu=neon,g`
209 export CXXFLAGS=`echo $CXXFLAGS | sed s,-mfpu=vfpv3,-mfpu=neon,g`
210 export FFLAGS=`echo $FFLAGS | sed s,-mfpu=vfpv3,-mfpu=neon,g`
211 %endif
212
213 %if "%{profile}" == "ivi"
214 GYP_EXTRA_FLAGS="${GYP_EXTRA_FLAGS} -Denable_murphy=1"
215 %endif
216
217 # --no-parallel is added because chroot does not mount a /dev/shm, this will
218 # cause python multiprocessing.SemLock error.
219 export GYP_GENERATORS='ninja'
220 ./src/xwalk/gyp_xwalk src/xwalk/xwalk.gyp \
221 --no-parallel \
222 ${GYP_EXTRA_FLAGS} \
223 -Dchromeos=0 \
224 -Dclang=0 \
225 -Dtizen=1 \
226 -Dpython_ver=2.7 \
227 -Duse_aura=1 \
228 -Duse_cups=0 \
229 -Duse_gconf=0 \
230 -Duse_gnome_keyring=0 \
231 -Duse_kerberos=0 \
232 -Duse_system_bzip2=1 \
233 -Duse_system_libexif=1 \
234 -Duse_system_libxml=1 \
235 -Duse_system_nspr=1 \
236 -Dshared_process_mode=1 \
237 -Denable_hidpi=1
238
239 ninja %{?_smp_mflags} -C src/out/Release xwalk xwalk_launcher xwalk_application_tools
240
241 %install
242 # Binaries.
243 install -p -D %{SOURCE2} %{buildroot}%{_dbusservicedir}/org.crosswalkproject.Runtime1.service
244 install -p -D xwalk.service %{buildroot}%{_systemduserservicedir}/xwalk.service
245 install -p -D src/out/Release/xwalk %{buildroot}%{_libdir}/xwalk/xwalk
246 install -p -D src/out/Release/xwalkctl %{buildroot}%{_bindir}/xwalkctl
247 install -p -D src/out/Release/xwalk-launcher %{buildroot}%{_bindir}/xwalk-launcher
248 install -p -D src/out/Release/lib/libxwalk-backendlib.so %{buildroot}%{_libdir}/xwalk/libxwalk-backendlib.so
249 install -p -D src/xwalk/application/tools/tizen/xwalk_backend_wrapper.sh %{buildroot}%{_libdir}/xwalk/xwalk_backend_wrapper.sh
250
251 # Supporting libraries and resources.
252 install -p -D src/out/Release/icudtl.dat %{buildroot}%{_libdir}/xwalk/icudtl.dat
253 install -p -D src/out/Release/libffmpegsumo.so %{buildroot}%{_libdir}/xwalk/libffmpegsumo.so
254 install -p -D src/out/Release/xwalk.pak %{buildroot}%{_libdir}/xwalk/xwalk.pak
255 mkdir -p %{buildroot}%{_datadir}/xwalk
256 install -p -D src/xwalk/application/common/tizen/configuration/*.xsd %{buildroot}%{_datadir}/xwalk/
257
258 # PNaCl
259 %if ! %{_disable_nacl}
260 install -p -D src/out/Release/nacl_bootstrap_raw %{buildroot}%{_libdir}/xwalk/nacl_bootstrap_raw
261 install -p -D src/out/Release/nacl_helper %{buildroot}%{_libdir}/xwalk/nacl_helper
262 install -p -D src/out/Release/nacl_helper_bootstrap %{buildroot}%{_libdir}/xwalk/nacl_helper_bootstrap
263 install -p -D src/out/Release/nacl_irt_*.nexe %{buildroot}%{_libdir}/xwalk
264 install -p -d %{buildroot}%{_libdir}/xwalk/pnacl
265 install -m 0664 -p -D src/out/Release/pnacl/* %{buildroot}%{_libdir}/xwalk/pnacl
266 %endif
267
268 # Register xwalk to the package manager.
269 install -p -D %{name}.xml %{buildroot}%{_manifestdir}/%{name}.xml
270 install -p -D %{name}.png %{buildroot}%{_desktop_icondir}/%{name}.png
271
272 %post
273 mkdir -p %{_desktop_icondir_ro}
274 mkdir -p %{_manifestdir_ro}
275
276 ln -sf %{_libdir}/xwalk/libxwalk-backendlib.so /etc/package-manager/backendlib/libxpk.so
277 ln -sf %{_libdir}/xwalk/libxwalk-backendlib.so /etc/package-manager/backendlib/libwgt.so
278 ln -sf %{_libdir}/xwalk/xwalk_backend_wrapper.sh /etc/package-manager/backend/xpk
279 ln -sf %{_libdir}/xwalk/xwalk_backend_wrapper.sh /etc/package-manager/backend/wgt
280
281 %preun
282 [ -L /etc/package-manager/backendlib/libxpk.so ] && rm /etc/package-manager/backendlib/libxpk.so
283 [ -L /etc/package-manager/backendlib/libwgt.so ] && rm /etc/package-manager/backendlib/libwgt.so
284 [ -L /etc/package-manager/backend/xpk ] && rm /etc/package-manager/backend/xpk
285 [ -L /etc/package-manager/backend/wgt ] && rm /etc/package-manager/backend/wgt
286
287 %files
288 %manifest %{name}.manifest
289 %license AUTHORS.chromium LICENSE.chromium LICENSE.xwalk
290 %{_bindir}/xwalkctl
291 %{_bindir}/xwalk-launcher
292 %{_libdir}/xwalk/icudtl.dat
293 %{_libdir}/xwalk/libffmpegsumo.so
294 %if ! %{_disable_nacl}
295 %{_libdir}/xwalk/nacl_bootstrap_raw
296 %{_libdir}/xwalk/nacl_helper
297 %{_libdir}/xwalk/nacl_helper_bootstrap
298 %{_libdir}/xwalk/nacl_irt_*.nexe
299 %{_libdir}/xwalk/pnacl/*
300 %endif
301 %{_libdir}/xwalk/xwalk
302 %{_libdir}/xwalk/xwalk.pak
303 %{_libdir}/xwalk/libxwalk-backendlib.so
304 %{_libdir}/xwalk/xwalk_backend_wrapper.sh
305 %{_manifestdir}/%{name}.xml
306 %{_desktop_icondir}/%{name}.png
307 %{_dbusservicedir}/org.crosswalkproject.Runtime1.service
308 %{_systemduserservicedir}/xwalk.service
309 %{_datadir}/xwalk/*