Tizen: Support Ethernet/3G Status Monitoring in IP Adapter
[contrib/iotivity.git] / service / easy-setup / sampleapp / enrollee / tizen-sdb / EnrolleeSample / packaging / com.oic.es.sample.spec
1 %define PREFIX /usr/apps/com.oic.es.sample
2 %define ROOTDIR  %{_builddir}/%{name}-%{version}
3 %{!?VERBOSE: %define VERBOSE 1}
4
5 Name: com-oic-es-sample
6 Version:    1.2.0
7 Release:    0
8 Summary: Tizen adapter interfacesample application
9 URL: http://slp-source.sec.samsung.net
10 Source: %{name}-%{version}.tar.gz
11 License: Apache-2.0
12 Group: Applications/OICSample
13 BuildRequires: pkgconfig(dlog)
14 BuildRequires: pkgconfig(glib-2.0)
15 BuildRequires: pkgconfig(gio-2.0)
16 BuildRequires: pkgconfig(gthread-2.0)
17 BuildRequires: boost-devel
18 BuildRequires: boost-thread
19 BuildRequires: boost-system
20 BuildRequires: boost-filesystem
21 BuildRequires: pkgconfig(capi-network-connection)
22 BuildRequires: pkgconfig(capi-network-wifi)
23 BuildRequires: pkgconfig(capi-network-bluetooth)
24 BuildRequires: scons
25 BuildRequires: iotivity
26 BuildRequires: iotivity-devel
27 BuildRequires: iotivity-service
28
29 ## If tizen 2.x, RELEASE follows tizen_build_binary_release_type_eng. ##
30 ## and if tizen 3.0, RELEASE follows tizen_build_devel_mode. ##
31 %if 0%{?tizen_build_devel_mode} == 1 || 0%{?tizen_build_binary_release_type_eng} == 1
32 %define RELEASE False
33 %else
34 %define RELEASE True
35 %endif
36
37 %{!?TARGET_TRANSPORT: %define TARGET_TRANSPORT IP}
38 %{!?SECURED: %define SECURED 1}
39 %{!?LOGGING: %define LOGGING True}
40 %{!?ROUTING: %define ROUTING EP}
41 %{!?ES_TARGET_ENROLLEE: %define ES_TARGET_ENROLLEE tizen}
42 %{!?VERBOSE: %define VERBOSE 1}
43
44 %description
45 EasySetup Sample application
46
47 %prep
48 %setup -q
49
50 %build
51
52 scons VERBOSE=%{VERBOSE} TARGET_OS=tizen LOGGING=True TARGET_TRANSPORT=%{TARGET_TRANSPORT} SECURED=%{SECURED} RELEASE=%{RELEASE} ROUTING=%{ROUTING} ES_TARGET_ENROLLEE=%{ES_TARGET_ENROLLEE}
53
54 %install
55
56 mkdir -p %{buildroot}%{_datadir}/packages
57 mkdir -p %{buildroot}/%{_sysconfdir}/smack/accesses2.d
58 mkdir -p %{buildroot}/usr/apps/com.oic.es.sample/bin/
59 mkdir -p %{buildroot}/usr/apps/com.oic.es.sample/bin/internal
60
61 cp -rf %{ROOTDIR}/com.oic.es.sample.xml %{buildroot}/%{_datadir}/packages
62 cp -rf %{ROOTDIR}/scons/enrollee_wifi %{buildroot}/usr/apps/com.oic.es.sample/bin/
63
64 %files
65 %manifest com.oic.es.sample.manifest
66 %defattr(-,root,root,-)
67 /usr/apps/com.oic.es.sample/bin/enrollee_wifi
68 /%{_datadir}/packages/com.oic.es.sample.xml
69
70