- translate rpm.8 man page (Peter Ivanyi <ivanyi@internet.sk>).
[platform/upstream/rpm.git] / rpm.spec
1 # XXX legacy requires './' payload prefix to be omitted from rpm packages.
2 %define _noPayloadPrefix        1
3
4 %define __prefix        /usr
5 %{expand:%%define __share %(if [ -d %{__prefix}/share/man ]; then echo /share ; else echo %%{nil} ; fi)}
6
7 Summary: The Red Hat package management system.
8 Name: rpm
9 %define version 4.1
10 Version: %{version}
11 Release: 0.1
12 Group: System Environment/Base
13 Source: ftp://ftp.rpm.org/pub/rpm/dist/rpm-3.0.x/rpm-%{version}.tar.gz
14 Copyright: GPL
15 Conflicts: patch < 2.5
16 %ifos linux
17 Prereq: gawk fileutils textutils sh-utils mktemp
18 Requires: popt, bzip2 >= 0.9.0c-2
19 # XXX glibc-2.1.92 has incompatible locale changes that affect statically
20 # XXX linked binaries like /bin/rpm.
21 %ifnarch ia64
22 Requires: glibc >= 2.1.92
23 %endif
24 # XXX needed to avoid libdb.so.2 satisfied by compat/libc5 provides.
25 Requires: db1 = 1.85
26 BuildRequires: db3-devel
27 BuildRequires: bzip2 >= 0.9.0c-2
28 BuildRequires: python-devel >= 1.5.2
29 %endif
30 BuildRoot: %{_tmppath}/%{name}-root
31
32 %description
33 The RPM Package Manager (RPM) is a powerful command line driven
34 package management system capable of installing, uninstalling,
35 verifying, querying, and updating software packages.  Each software
36 package consists of an archive of files along with information about
37 the package like its version, a description, etc.
38
39 %package devel
40 Summary: Development files for applications which will manipulate RPM packages.
41 Group: Development/Libraries
42 Requires: rpm = %{version}, popt
43
44 %description devel
45 This package contains the RPM C library and header files.  These
46 development files will simplify the process of writing programs which
47 manipulate RPM packages and databases. These files are intended to
48 simplify the process of creating graphical package managers or any
49 other tools that need an intimate knowledge of RPM packages in order
50 to function.
51
52 This package should be installed if you want to develop programs that
53 will manipulate RPM packages and databases.
54
55 %package build
56 Summary: Scripts and executable programs used to build packages.
57 Group: Development/Tools
58 Requires: rpm = %{version}
59
60 %description build
61 This package contains scripts and executable programs that are used to
62 build packages using RPM.
63
64 %ifos linux
65 %package python
66 Summary: Python bindings for apps which will manipulate RPM packages.
67 Group: Development/Libraries
68 BuildRequires: popt >= 1.5
69 Requires: popt >= 1.5
70 Requires: python >= 1.5.2
71
72 %description python
73 The rpm-python package contains a module which permits applications
74 written in the Python programming language to use the interface
75 supplied by RPM (RPM Package Manager) libraries.
76
77 This package should be installed if you want to develop Python
78 programs that will manipulate RPM packages and databases.
79 %endif
80
81 %package -n popt
82 Summary: A C library for parsing command line parameters.
83 Group: Development/Libraries
84 Version: 1.6
85
86 %description -n popt
87 Popt is a C library for parsing command line parameters.  Popt was
88 heavily influenced by the getopt() and getopt_long() functions, but it
89 improves on them by allowing more powerful argument expansion.  Popt
90 can parse arbitrary argv[] style arrays and automatically set
91 variables based on command line arguments.  Popt allows command line
92 arguments to be aliased via configuration files and includes utility
93 functions for parsing arbitrary strings into argv[] arrays using
94 shell-like rules.
95
96 Install popt if you're a C programmer and you'd like to use its
97 capabilities.
98
99 %prep
100 %setup -q
101
102 %build
103 %ifos linux
104 CFLAGS="$RPM_OPT_FLAGS" ./configure --prefix=%{__prefix} --sysconfdir=/etc --localstatedir=/var --infodir='${prefix}%{__share}/info' --mandir='${prefix}%{__share}/man'
105 %else
106 CFLAGS="$RPM_OPT_FLAGS" ./configure --prefix=%{__prefix}
107 %endif
108
109 make
110
111 %ifos linux
112 make -C python
113 %endif
114
115 %install
116 rm -rf $RPM_BUILD_ROOT
117
118 make DESTDIR="$RPM_BUILD_ROOT" install
119 %ifos linux
120 make DESTDIR="$RPM_BUILD_ROOT" install -C python
121 %endif
122 mkdir -p $RPM_BUILD_ROOT/etc/rpm
123
124 { cd $RPM_BUILD_ROOT
125   strip ./bin/rpm
126   strip .%{__prefix}/bin/rpm2cpio
127 }
128
129 %clean
130 rm -rf $RPM_BUILD_ROOT
131
132 %post
133 /sbin/ldconfig
134 %ifos linux
135 if [ ! -e /etc/rpm/macros -a -e /etc/rpmrc -a -f %{__prefix}/lib/rpm/convertrpmrc.sh ] 
136 then
137         sh %{__prefix}/lib/rpm/convertrpmrc.sh > /dev/null 2>&1
138 fi
139 %else
140 /bin/rpm --initdb
141 %endif
142
143 %postun -p /sbin/ldconfig
144
145 %ifos linux
146 %post devel -p /sbin/ldconfig
147 %postun devel -p /sbin/ldconfig
148
149 %post -n popt -p /sbin/ldconfig
150 %postun -n popt -p /sbin/ldconfig
151 %endif
152
153 %ifos linux
154 %post python -p /sbin/ldconfig
155 %postun python -p /sbin/ldconfig
156 %endif
157
158 %files
159 %defattr(-,root,root)
160 %doc RPM-PGP-KEY RPM-GPG-KEY CHANGES GROUPS doc/manual/[a-z]*
161 /bin/rpm
162 %dir /etc/rpm
163 %{__prefix}/bin/rpm2cpio
164 %{__prefix}/bin/gendiff
165 %{__prefix}/bin/rpmdb
166 %{__prefix}/bin/rpm[eiukqv]
167 %{__prefix}/bin/rpmsign
168 %{__prefix}/bin/rpmquery
169 %{__prefix}/bin/rpmverify
170 %{__prefix}/lib/librpm.so.*
171 %{__prefix}/lib/librpmio.so.*
172 %{__prefix}/lib/librpmbuild.so.*
173
174 %{__prefix}/lib/rpm/config.guess
175 %{__prefix}/lib/rpm/config.sub
176 %{__prefix}/lib/rpm/convertrpmrc.sh
177 %{__prefix}/lib/rpm/macros
178 %{__prefix}/lib/rpm/mkinstalldirs
179 %{__prefix}/lib/rpm/rpmdb
180 %{__prefix}/lib/rpm/rpm[eiukqv]
181 %{__prefix}/lib/rpm/rpmpopt*
182 %{__prefix}/lib/rpm/rpmrc
183
184 %ifarch i386 i486 i586 i686
185 %{__prefix}/lib/rpm/i[3456]86*
186 %endif
187 %ifarch alpha
188 %{__prefix}/lib/rpm/alpha*
189 %endif
190 %ifarch sparc sparc64
191 %{__prefix}/lib/rpm/sparc*
192 %endif
193 %ifarch ia64
194 %{__prefix}/lib/rpm/ia64*
195 %endif
196 %ifarch powerpc ppc
197 %{__prefix}/lib/rpm/ppc*
198 %endif
199
200 %dir %{__prefix}/src/redhat
201 %dir %{__prefix}/src/redhat/BUILD
202 %dir %{__prefix}/src/redhat/SPECS
203 %dir %{__prefix}/src/redhat/SOURCES
204 %dir %{__prefix}/src/redhat/SRPMS
205 %dir %{__prefix}/src/redhat/RPMS
206 %{__prefix}/src/redhat/RPMS/*
207 %{__prefix}/*/locale/*/LC_MESSAGES/rpm.mo
208 %{__prefix}%{__share}/man/man[18]/*.[18]*
209 %lang(pl) %{__prefix}%{__share}/man/pl/man[18]/*.[18]*
210 %lang(ru) %{__prefix}%{__share}/man/ru/man[18]/*.[18]*
211 %lang(sk) %{__prefix}%{__share}/man/sk/man[18]/*.[18]*
212
213 %files build
214 %defattr(-,root,root)
215 %{__prefix}/bin/rpmbuild
216 %{__prefix}/lib/rpm/brp-*
217 %{__prefix}/lib/rpm/check-prereqs
218 %{__prefix}/lib/rpm/cpanflute
219 %{__prefix}/lib/rpm/find-lang.sh
220 %{__prefix}/lib/rpm/find-prov.pl
221 %{__prefix}/lib/rpm/find-provides
222 %{__prefix}/lib/rpm/find-provides.perl
223 %{__prefix}/lib/rpm/find-req.pl
224 %{__prefix}/lib/rpm/find-requires
225 %{__prefix}/lib/rpm/find-requires.perl
226 %{__prefix}/lib/rpm/get_magic.pl
227 %{__prefix}/lib/rpm/getpo.sh
228 %{__prefix}/lib/rpm/http.req
229 %{__prefix}/lib/rpm/magic.prov
230 %{__prefix}/lib/rpm/magic.req
231 %{__prefix}/lib/rpm/perl.prov
232 %{__prefix}/lib/rpm/perl.req
233 %{__prefix}/lib/rpm/rpm[bt]
234 %{__prefix}/lib/rpm/rpmdiff
235 %{__prefix}/lib/rpm/rpmdiff.cgi
236 %{__prefix}/lib/rpm/u_pkg.sh
237 %{__prefix}/lib/rpm/vpkg-provides.sh
238 %{__prefix}/lib/rpm/vpkg-provides2.sh
239
240 %ifos linux
241 %files python
242 %defattr(-,root,root)
243 %{__prefix}/lib/python1.5/site-packages/rpmmodule.so
244 %endif
245
246 %files devel
247 %defattr(-,root,root)
248 %{__prefix}/include/rpm
249 %{__prefix}/lib/librpm.a
250 %{__prefix}/lib/librpm.la
251 %{__prefix}/lib/librpm.so
252 %{__prefix}/lib/librpmio.a
253 %{__prefix}/lib/librpmio.la
254 %{__prefix}/lib/librpmio.so
255 %{__prefix}/lib/librpmbuild.a
256 %{__prefix}/lib/librpmbuild.la
257 %{__prefix}/lib/librpmbuild.so
258
259 %files -n popt
260 %defattr(-,root,root)
261 %{__prefix}/lib/libpopt.so.*
262 %{__prefix}/*/locale/*/LC_MESSAGES/popt.mo
263 %{__prefix}%{__share}/man/man3/popt.3*
264
265 # XXX These may end up in popt-devel but it hardly seems worth the effort now.
266 %{__prefix}/lib/libpopt.a
267 %{__prefix}/lib/libpopt.la
268 %{__prefix}/lib/libpopt.so
269 %{__prefix}/include/popt.h
270
271 %changelog
272 * Wed Aug 16 2000 Jeff Johnson <jbj@redhat.com>
273 - start rpm 4.1 development.