- wire --nodigest/--nosignature options to checksig/query/verify modes.
[platform/upstream/rpm.git] / rpm.spec
1 %define with_python_subpackage  1%{nil}
2 %define with_python_version     2.2%{nil}
3 %define with_perl_subpackage    1
4 %define with_bzip2              1%{nil}
5 %define with_apidocs            0%{nil}
6 %define with_internal_db        1%{nil}
7 %define strip_binaries          1
8
9 # XXX enable at your own risk, CDB access to rpmdb isn't cooked yet.
10 %define enable_cdb              create cdb
11
12 # XXX legacy requires './' payload prefix to be omitted from rpm packages.
13 %define _noPayloadPrefix        1
14
15 %define __prefix        /usr
16 %{expand: %%define __share %(if [ -d %{__prefix}/share/man ]; then echo /share ; else echo %%{nil} ; fi)}
17
18 Summary: The Red Hat package management system.
19 Name: rpm
20 %define version 4.1
21 Version: %{version}
22 %{expand: %%define rpm_version %{version}}
23 Release: 0.01
24 Group: System Environment/Base
25 Source: ftp://ftp.rpm.org/pub/rpm/dist/rpm-4.0.x/rpm-%{rpm_version}.tar.gz
26 Copyright: GPL
27 Conflicts: patch < 2.5
28 %ifos linux
29 Prereq: gawk fileutils textutils mktemp shadow-utils
30 %endif
31 Requires: popt = 1.7
32
33 %if !%{with_internal_db}
34 BuildRequires: db3-devel
35
36 # XXX glibc-2.1.92 has incompatible locale changes that affect statically
37 # XXX linked binaries like /bin/rpm.
38 %ifnarch ia64
39 Requires: glibc >= 2.1.92
40 %endif
41 %endif
42
43 BuildRequires: zlib-devel
44 # XXX Red Hat 5.2 has not bzip2 or python
45 %if %{with_bzip2}
46 BuildRequires: bzip2 >= 0.9.0c-2
47 %endif
48 %if %{with_python_subpackage}
49 BuildRequires: python-devel >= %{with_python_version}
50 %endif
51 %if %{with_perl_subpackage}
52 BuildRequires: perl >= 0:5.00503
53 %endif
54
55 BuildRoot: %{_tmppath}/%{name}-root
56
57 %description
58 The RPM Package Manager (RPM) is a powerful command line driven
59 package management system capable of installing, uninstalling,
60 verifying, querying, and updating software packages.  Each software
61 package consists of an archive of files along with information about
62 the package like its version, a description, etc.
63
64 %package devel
65 Summary: Development files for applications which will manipulate RPM packages.
66 Group: Development/Libraries
67 Requires: rpm = %{rpm_version}, popt = 1.7
68
69 %description devel
70 This package contains the RPM C library and header files.  These
71 development files will simplify the process of writing programs which
72 manipulate RPM packages and databases. These files are intended to
73 simplify the process of creating graphical package managers or any
74 other tools that need an intimate knowledge of RPM packages in order
75 to function.
76
77 This package should be installed if you want to develop programs that
78 will manipulate RPM packages and databases.
79
80 %package build
81 Summary: Scripts and executable programs used to build packages.
82 Group: Development/Tools
83 Requires: rpm = %{rpm_version}
84
85 %description build
86 This package contains scripts and executable programs that are used to
87 build packages using RPM.
88
89 %if %{with_python_subpackage}
90 %package python
91 Summary: Python bindings for apps which will manipulate RPM packages.
92 Group: Development/Libraries
93 Requires: rpm = %{rpm_version}
94 Requires: python >= %{with_python_version}
95 Requires: popt = 1.7
96
97 %description python
98 The rpm-python package contains a module which permits applications
99 written in the Python programming language to use the interface
100 supplied by RPM (RPM Package Manager) libraries.
101
102 This package should be installed if you want to develop Python
103 programs that will manipulate RPM packages and databases.
104 %endif
105
106 %if %{with_perl_subpackage}
107 %package perl
108 Summary: Native bindings to the RPM API for Perl.
109 Group: Development/Languages
110 URL: http://www.cpan.org
111 Provides: perl(RPM::Database) = %{rpm_version}
112 Provides: perl(RPM::Header) = %{rpm_version}
113 Requires: rpm = %{rpm_version}
114 Requires: perl >= 0:5.00503
115 Requires: popt = 1.7
116 Obsoletes: perl-Perl-RPM
117
118 %description perl
119 The Perl-RPM module is an attempt to provide Perl-level access to the
120 complete application programming interface that is a part of the Red
121 Hat Package Manager (RPM). Rather than have scripts rely on executing
122 RPM commands and parse the resulting output, this module aims to give
123 Perl programmers the ability to do anything that would otherwise have
124 been done in C or C++.
125
126 The interface is being designed and laid out as a collection of
127 classes, at least some of which are also available as tied-hash
128 implementations.
129
130 At this time, the interface only provides access to the database of
131 installed packages, and header data retrieval for RPM and SRPM files
132 is not yet installed.  Error management and the export of most defined
133 constants, through RPM::Error and RPM::Constants, respectively, are
134 also available.
135
136 %endif
137
138 %package -n popt
139 Summary: A C library for parsing command line parameters.
140 Group: Development/Libraries
141 Version: 1.7
142
143 %description -n popt
144 Popt is a C library for parsing command line parameters.  Popt was
145 heavily influenced by the getopt() and getopt_long() functions, but it
146 improves on them by allowing more powerful argument expansion.  Popt
147 can parse arbitrary argv[] style arrays and automatically set
148 variables based on command line arguments.  Popt allows command line
149 arguments to be aliased via configuration files and includes utility
150 functions for parsing arbitrary strings into argv[] arrays using
151 shell-like rules.
152
153 Install popt if you're a C programmer and you'd like to use its
154 capabilities.
155
156 %prep
157 %setup -q
158
159 %build
160
161 %ifos linux
162 CFLAGS="$RPM_OPT_FLAGS" ./configure --prefix=%{__prefix} --sysconfdir=/etc --localstatedir=/var --infodir='${prefix}%{__share}/info' --mandir='${prefix}%{__share}/man'
163 %else
164 CFLAGS="$RPM_OPT_FLAGS" ./configure --prefix=%{__prefix}
165 %endif
166
167 # XXX workaround ia64 gcc-3.1-0.18 miscompilation
168 %ifarch ia64
169 make CFLAGS="-g -O0 -DIA64_SUCKS_ROCKS" files.o files.lo -C build
170 %endif
171
172 make
173
174 %if %{with_perl_subpackage}
175 { cd Perl-RPM
176   CFLAGS="$RPM_OPT_FLAGS" perl Makefile.PL
177   export SUBDIR="%{_builddir}/%{buildsubdir}"
178   make INC="-I. -I$SUBDIR/lib -I$SUBDIR/rpmdb -I$SUBDIR/rpmio -I$SUBDIR/popt" \
179     LDDLFLAGS="-shared -L$SUBDIR/lib/.libs -L$SUBDIR/rpmdb/.libs -L$SUBDIR/rpmio/.libs -L$SUBDIR/popt/.libs" %{?_smp_mflags}
180 }
181 %endif
182
183 %install
184 rm -rf $RPM_BUILD_ROOT
185
186 make DESTDIR="$RPM_BUILD_ROOT" install
187
188 %ifos linux
189
190 # Save list of packages through cron
191 mkdir -p ${RPM_BUILD_ROOT}/etc/cron.daily
192 install -m 755 scripts/rpm.daily ${RPM_BUILD_ROOT}/etc/cron.daily/rpm
193
194 mkdir -p ${RPM_BUILD_ROOT}/etc/logrotate.d
195 install -m 644 scripts/rpm.log ${RPM_BUILD_ROOT}/etc/logrotate.d/rpm
196
197 mkdir -p $RPM_BUILD_ROOT/etc/rpm
198 cat << E_O_F > $RPM_BUILD_ROOT/etc/rpm/macros.db1
199 %%_dbapi                1
200 E_O_F
201 cat << E_O_F > $RPM_BUILD_ROOT/etc/rpm/macros.cdb
202 %{?enable_cdb:#%%__dbi_cdb      %{enable_cdb}}
203 E_O_F
204
205 mkdir -p $RPM_BUILD_ROOT/var/lib/rpm
206 for dbi in \
207         Basenames Conflictname Dirnames Group Installtid Name Providename \
208         Provideversion Removetid Requirename Requireversion Triggername \
209         Sigmd5 Sha1header Filemd5s Packages \
210         __db.001 __db.002 __db.003 __db.004 __db.005 __db.006 __db.007 \
211         __db.008 __db.009
212 do
213     touch $RPM_BUILD_ROOT/var/lib/rpm/$dbi
214 done
215
216 %endif
217
218 %if %{with_apidocs}
219 gzip -9n apidocs/man/man*/* || :
220 %endif
221
222 %if %{with_perl_subpackage}
223 { cd Perl-RPM
224   eval `perl '-V:installsitearch'`
225   eval `perl '-V:installarchlib'`
226   mkdir -p $RPM_BUILD_ROOT/$installarchlib
227   make PREFIX=${RPM_BUILD_ROOT}%{__prefix} \
228     INSTALLMAN1DIR=${RPM_BUILD_ROOT}%{__prefix}%{__share}/man/man1 \
229     INSTALLMAN3DIR=${RPM_BUILD_ROOT}%{__prefix}%{__share}/man/man3 \
230         install
231   rm -f $RPM_BUILD_ROOT/$installarchlib/perllocal.pod
232   rm -f $RPM_BUILD_ROOT/$installsitearch/auto/RPM/.packlist
233   cd ..
234 }
235 %endif
236
237 %if %{strip_binaries}
238 { cd $RPM_BUILD_ROOT
239   %{__strip} ./bin/rpm
240   %{__strip} .%{__prefix}/bin/rpm2cpio
241 }
242 %endif
243
244 %clean
245 rm -rf $RPM_BUILD_ROOT
246
247 %pre
248 %ifos linux
249 if [ -f /var/lib/rpm/Packages -a -f /var/lib/rpm/packages.rpm ]; then
250     echo "
251 You have both
252         /var/lib/rpm/packages.rpm       db1 format installed package headers
253         /var/lib/rpm/Packages           db3 format installed package headers
254 Please remove (or at least rename) one of those files, and re-install.
255 "
256     exit 1
257 fi
258 /usr/sbin/groupadd -g 37 rpm                            > /dev/null 2>&1
259 /usr/sbin/useradd  -r -d /var/lib/rpm -u 37 -g 37 rpm   > /dev/null 2>&1
260 %endif
261 exit 0
262
263 %post
264 %ifos linux
265 /sbin/ldconfig
266 if [ -f /var/lib/rpm/packages.rpm ]; then
267     /bin/chown rpm.rpm /var/lib/rpm/*.rpm
268 elif [ -f /var/lib/rpm/Packages ]; then
269     # undo db1 configuration
270     rm -f /etc/rpm/macros.db1
271     /bin/chown rpm.rpm /var/lib/rpm/[A-Z]*
272 else
273     # initialize db3 database
274     rm -f /etc/rpm/macros.db1
275     /bin/rpm --initdb
276 fi
277 %endif
278 exit 0
279
280 %ifos linux
281 %postun
282 /sbin/ldconfig
283 if [ $1 = 0 ]; then
284     /usr/sbin/userdel rpm
285     /usr/sbin/groupdel rpm
286 fi
287
288
289 %post devel -p /sbin/ldconfig
290 %postun devel -p /sbin/ldconfig
291
292 %post -n popt -p /sbin/ldconfig
293 %postun -n popt -p /sbin/ldconfig
294 %endif
295
296 %if %{with_python_subpackage}
297 %post python -p /sbin/ldconfig
298 %postun python -p /sbin/ldconfig
299 %endif
300
301 %define rpmattr         %attr(0755, rpm, rpm)
302
303 %files
304 %defattr(-,root,root)
305 %doc RPM-PGP-KEY RPM-GPG-KEY CHANGES GROUPS doc/manual/[a-z]*
306 %attr(0755, rpm, rpm)   /bin/rpm
307
308 %ifos linux
309 %config(noreplace,missingok)    /etc/cron.daily/rpm
310 %config(noreplace,missingok)    /etc/logrotate.d/rpm
311 %dir                            /etc/rpm
312 %config(noreplace,missingok)    /etc/rpm/macros.*
313 %attr(0755, rpm, rpm)   %dir /var/lib/rpm
314
315 %define rpmdbattr %attr(0644, rpm, rpm) %verify(not md5 size mtime) %ghost %config(missingok,noreplace)
316 %rpmdbattr      /var/lib/rpm/Basenames
317 %rpmdbattr      /var/lib/rpm/Conflictname
318 %rpmdbattr      /var/lib/rpm/__db.0*
319 %rpmdbattr      /var/lib/rpm/Dirnames
320 %rpmdbattr      /var/lib/rpm/Filemd5s
321 %rpmdbattr      /var/lib/rpm/Group
322 %rpmdbattr      /var/lib/rpm/Installtid
323 %rpmdbattr      /var/lib/rpm/Name
324 %rpmdbattr      /var/lib/rpm/Packages
325 %rpmdbattr      /var/lib/rpm/Providename
326 %rpmdbattr      /var/lib/rpm/Provideversion
327 %rpmdbattr      /var/lib/rpm/Removetid
328 %rpmdbattr      /var/lib/rpm/Requirename
329 %rpmdbattr      /var/lib/rpm/Requireversion
330 %rpmdbattr      /var/lib/rpm/Sigmd5
331 %rpmdbattr      /var/lib/rpm/Sha1header
332 %rpmdbattr      /var/lib/rpm/Triggername
333
334 %endif
335
336 %rpmattr        %{__prefix}/bin/rpm2cpio
337 %rpmattr        %{__prefix}/bin/gendiff
338 %rpmattr        %{__prefix}/bin/rpmdb
339 #%rpmattr       %{__prefix}/bin/rpm[eiu]
340 %rpmattr        %{__prefix}/bin/rpmsign
341 %rpmattr        %{__prefix}/bin/rpmquery
342 %rpmattr        %{__prefix}/bin/rpmverify
343
344 %{__prefix}/lib/librpm-4.1.so
345 %{__prefix}/lib/librpmdb-4.1.so
346 %{__prefix}/lib/librpmio-4.1.so
347 %{__prefix}/lib/librpmbuild-4.1.so
348
349 %attr(0755, rpm, rpm)   %dir %{__prefix}/lib/rpm
350 %rpmattr        %{__prefix}/lib/rpm/config.guess
351 %rpmattr        %{__prefix}/lib/rpm/config.sub
352 %rpmattr        %{__prefix}/lib/rpm/convertrpmrc.sh
353 %attr(0644, rpm, rpm)   %{__prefix}/lib/rpm/macros
354 %rpmattr        %{__prefix}/lib/rpm/mkinstalldirs
355 %rpmattr        %{__prefix}/lib/rpm/rpm.*
356 %rpmattr        %{__prefix}/lib/rpm/rpm2cpio.sh
357 %rpmattr        %{__prefix}/lib/rpm/rpm[deiukqv]
358 %attr(0644, rpm, rpm)   %{__prefix}/lib/rpm/rpmpopt*
359 %attr(0644, rpm, rpm)   %{__prefix}/lib/rpm/rpmrc
360
361 %ifarch i386 i486 i586 i686 athlon
362 %attr(-, rpm, rpm)              %{__prefix}/lib/rpm/i[3456]86*
363 %attr(-, rpm, rpm)              %{__prefix}/lib/rpm/athlon*
364 %endif
365 %ifarch alpha alphaev5 alphaev56 alphapca56 alphaev6 alphaev67
366 %attr(-, rpm, rpm)              %{__prefix}/lib/rpm/alpha*
367 %endif
368 %ifarch sparc sparcv9 sparc64
369 %attr(-, rpm, rpm)              %{__prefix}/lib/rpm/sparc*
370 %endif
371 %ifarch ia64
372 %attr(-, rpm, rpm)              %{__prefix}/lib/rpm/ia64*
373 %endif
374 %ifarch powerpc ppc ppciseries ppcpseries ppcmac
375 %attr(-, rpm, rpm)              %{__prefix}/lib/rpm/ppc*
376 %endif
377 %ifarch s390 s390x
378 %attr(-, rpm, rpm)              %{__prefix}/lib/rpm/s390*
379 %endif
380 %ifarch armv3l armv4l
381 %attr(-, rpm, rpm)              %{__prefix}/lib/rpm/armv[34][lb]*
382 %endif
383 %ifarch mips mipsel mipseb
384 %attr(-, rpm, rpm)              %{__prefix}/lib/rpm/mips*
385 %endif
386 %attr(-, rpm, rpm)              %{__prefix}/lib/rpm/noarch*
387
388 %lang(cs)       %{__prefix}/*/locale/cs/LC_MESSAGES/rpm.mo
389 %lang(da)       %{__prefix}/*/locale/da/LC_MESSAGES/rpm.mo
390 %lang(de)       %{__prefix}/*/locale/de/LC_MESSAGES/rpm.mo
391 %lang(fi)       %{__prefix}/*/locale/fi/LC_MESSAGES/rpm.mo
392 %lang(fr)       %{__prefix}/*/locale/fr/LC_MESSAGES/rpm.mo
393 %lang(is)       %{__prefix}/*/locale/is/LC_MESSAGES/rpm.mo
394 %lang(ja)       %{__prefix}/*/locale/ja/LC_MESSAGES/rpm.mo
395 %lang(ko)       %{__prefix}/*/locale/ko/LC_MESSAGES/rpm.mo
396 %lang(no)       %{__prefix}/*/locale/no/LC_MESSAGES/rpm.mo
397 %lang(pl)       %{__prefix}/*/locale/pl/LC_MESSAGES/rpm.mo
398 %lang(pt)       %{__prefix}/*/locale/pt/LC_MESSAGES/rpm.mo
399 %lang(pt_BR)    %{__prefix}/*/locale/pt_BR/LC_MESSAGES/rpm.mo
400 %lang(ro)       %{__prefix}/*/locale/ro/LC_MESSAGES/rpm.mo
401 %lang(ru)       %{__prefix}/*/locale/ru/LC_MESSAGES/rpm.mo
402 %lang(sk)       %{__prefix}/*/locale/sk/LC_MESSAGES/rpm.mo
403 %lang(sl)       %{__prefix}/*/locale/sl/LC_MESSAGES/rpm.mo
404 %lang(sr)       %{__prefix}/*/locale/sr/LC_MESSAGES/rpm.mo
405 %lang(sv)       %{__prefix}/*/locale/sv/LC_MESSAGES/rpm.mo
406 %lang(tr)       %{__prefix}/*/locale/tr/LC_MESSAGES/rpm.mo
407
408 %{__prefix}%{__share}/man/man1/gendiff.1*
409 %{__prefix}%{__share}/man/man8/rpm.8*
410 %{__prefix}%{__share}/man/man8/rpm2cpio.8*
411 %lang(pl)       %{__prefix}%{__share}/man/pl/man[18]/*.[18]*
412 %lang(ru)       %{__prefix}%{__share}/man/ru/man[18]/*.[18]*
413 %lang(sk)       %{__prefix}%{__share}/man/sk/man[18]/*.[18]*
414
415 %files build
416 %defattr(-,root,root)
417 %dir %{__prefix}/src/redhat
418 %dir %{__prefix}/src/redhat/BUILD
419 %dir %{__prefix}/src/redhat/SPECS
420 %dir %{__prefix}/src/redhat/SOURCES
421 %dir %{__prefix}/src/redhat/SRPMS
422 %dir %{__prefix}/src/redhat/RPMS
423 %{__prefix}/src/redhat/RPMS/*
424 %rpmattr        %{__prefix}/bin/rpmbuild
425 %rpmattr        %{__prefix}/lib/rpm/brp-*
426 %rpmattr        %{__prefix}/lib/rpm/check-prereqs
427 %rpmattr        %{__prefix}/lib/rpm/config.site
428 %rpmattr        %{__prefix}/lib/rpm/cpanflute
429 %rpmattr        %{__prefix}/lib/rpm/cpanflute2
430 %rpmattr        %{__prefix}/lib/rpm/cross-build
431 %rpmattr        %{__prefix}/lib/rpm/find-lang.sh
432 %rpmattr        %{__prefix}/lib/rpm/find-prov.pl
433 %rpmattr        %{__prefix}/lib/rpm/find-provides
434 %rpmattr        %{__prefix}/lib/rpm/find-provides.perl
435 %rpmattr        %{__prefix}/lib/rpm/find-req.pl
436 %rpmattr        %{__prefix}/lib/rpm/find-requires
437 %rpmattr        %{__prefix}/lib/rpm/find-requires.perl
438 %rpmattr        %{__prefix}/lib/rpm/get_magic.pl
439 %rpmattr        %{__prefix}/lib/rpm/getpo.sh
440 %rpmattr        %{__prefix}/lib/rpm/http.req
441 %rpmattr        %{__prefix}/lib/rpm/javadeps
442 %rpmattr        %{__prefix}/lib/rpm/magic.prov
443 %rpmattr        %{__prefix}/lib/rpm/magic.req
444 %rpmattr        %{__prefix}/lib/rpm/perl.prov
445 %rpmattr        %{__prefix}/lib/rpm/Specfile.pm
446
447 # XXX remove executable bit to disable autogenerated perl requires for now.
448 %rpmattr        %{__prefix}/lib/rpm/perl.req
449 #%attr(0644, rpm, rpm) %{__prefix}/lib/rpm/perl.req
450
451 %rpmattr        %{__prefix}/lib/rpm/rpm[bt]
452 %rpmattr        %{__prefix}/lib/rpm/rpmdiff
453 %rpmattr        %{__prefix}/lib/rpm/rpmdiff.cgi
454 %rpmattr        %{__prefix}/lib/rpm/trpm
455 %rpmattr        %{__prefix}/lib/rpm/u_pkg.sh
456 %rpmattr        %{__prefix}/lib/rpm/vpkg-provides.sh
457 %rpmattr        %{__prefix}/lib/rpm/vpkg-provides2.sh
458
459 %{__prefix}%{__share}/man/man8/rpmbuild.8*
460
461 %if %{with_python_subpackage}
462 %files python
463 %defattr(-,root,root)
464 %{__prefix}/lib/python%{with_python_version}/site-packages/rpmmodule.so
465 #%{__prefix}/lib/python%{with_python_version}/site-packages/poptmodule.so
466 %endif
467
468 %if %{with_perl_subpackage}
469 %files perl
470 %defattr(-,root,root)
471 %rpmattr        %{__prefix}/bin/rpmprune
472 %{perl_sitearch}/auto/*
473 %{perl_sitearch}/RPM
474 %{perl_sitearch}/RPM.pm
475 %{__prefix}%{__share}/man/man1/rpmprune.1*
476 %{__prefix}%{__share}/man/man3/RPM*
477 %endif
478
479 %files devel
480 %defattr(-,root,root)
481 %if %{with_apidocs}
482 %doc 
483 %endif
484 %{__prefix}/include/rpm
485 %{__prefix}/lib/librpm.a
486 %{__prefix}/lib/librpm.la
487 %{__prefix}/lib/librpm.so
488 %{__prefix}/lib/librpmdb.a
489 %{__prefix}/lib/librpmdb.la
490 %{__prefix}/lib/librpmdb.so
491 %{__prefix}/lib/librpmio.a
492 %{__prefix}/lib/librpmio.la
493 %{__prefix}/lib/librpmio.so
494 %{__prefix}/lib/librpmbuild.a
495 %{__prefix}/lib/librpmbuild.la
496 %{__prefix}/lib/librpmbuild.so
497
498 %files -n popt
499 %defattr(-,root,root)
500 %{__prefix}/lib/libpopt.so.*
501 %{__prefix}%{__share}/man/man3/popt.3*
502 %lang(cs)       %{__prefix}/*/locale/cs/LC_MESSAGES/popt.mo
503 %lang(da)       %{__prefix}/*/locale/da/LC_MESSAGES/popt.mo
504 %lang(gl)       %{__prefix}/*/locale/gl/LC_MESSAGES/popt.mo
505 %lang(hu)       %{__prefix}/*/locale/hu/LC_MESSAGES/popt.mo
506 %lang(is)       %{__prefix}/*/locale/is/LC_MESSAGES/popt.mo
507 %lang(ko)       %{__prefix}/*/locale/ko/LC_MESSAGES/popt.mo
508 %lang(no)       %{__prefix}/*/locale/no/LC_MESSAGES/popt.mo
509 %lang(pt)       %{__prefix}/*/locale/pt/LC_MESSAGES/popt.mo
510 %lang(ro)       %{__prefix}/*/locale/ro/LC_MESSAGES/popt.mo
511 %lang(ru)       %{__prefix}/*/locale/ru/LC_MESSAGES/popt.mo
512 %lang(sk)       %{__prefix}/*/locale/sk/LC_MESSAGES/popt.mo
513 %lang(sl)       %{__prefix}/*/locale/sl/LC_MESSAGES/popt.mo
514 %lang(sv)       %{__prefix}/*/locale/sv/LC_MESSAGES/popt.mo
515 %lang(tr)       %{__prefix}/*/locale/tr/LC_MESSAGES/popt.mo
516 %lang(uk)       %{__prefix}/*/locale/uk/LC_MESSAGES/popt.mo
517 %lang(wa)       %{__prefix}/*/locale/wa/LC_MESSAGES/popt.mo
518 %lang(zh_CN)    %{__prefix}/*/locale/zh_CN.GB2312/LC_MESSAGES/popt.mo
519
520 # XXX These may end up in popt-devel but it hardly seems worth the effort now.
521 %{__prefix}/lib/libpopt.a
522 %{__prefix}/lib/libpopt.la
523 %{__prefix}/lib/libpopt.so
524 %{__prefix}/include/popt.h
525
526 %changelog
527 * Mon Sep 24 2001 Jeff Johnson <jbj@redhat.com>
528 - Start rpm-4.1.
529 - loosely wire beecrypt library into rpm.
530 - drop rpmio/base64.[ch] in favor of beecrypt versions.
531 - drop lib/md5*.[ch] files in favor of beecrypt.
532 - legacy: drop brokenMD5 support (rpm-2.3.3 to rpm-2.3.8 on sparc).
533 - eliminate DYING code.
534 - bind beecrypt md5/sha1 underneath rpmio.
535 - create RFC-2440 OpenPGP API in rpmio.
536 - proof-of-concept GPG/DSA verification for legacy signatures.
537 - upgrade to beecrypt-2.2.0pre.
538 - proof-of-concept PGP/RSA verification for legacy signatures.
539 - ratchet up to lclint "strict" level.
540 - upgrade to db-4.0.7.
541 - use only header methods, routines are now static.
542 - beecrypt is at least as good as pgp/gpg on verify, pulling the plug.
543 - add :base64 and :armor format extensions, dump binary tags in hex.
544 - proof-of-concept pubkey retrieval from RPM-{PGP,GPG}-KEY.
545 - stupid macros to configure public key file paths.
546 - all symbols but hdrVec are now forward references in linkage.
547 - generate an rpm header on the fly for imported pubkeys.
548 - wire transactions through rpmcli signature modes.
549 - wire transactions through rpmcli query/verify modes.
550 - wire transactions through rpmcli install/erase modes.
551 - legacy signatures always checked where possible on package read.
552 - wire transactions through rpmcli build modes.
553 - lazy rpmdb open/close through transaction methods (mostly anyways).
554 - no-brainer refcounts for rpmdb object.
555 - check added header against transaction set, replace if newer.
556 - transaction sets created in cli main.
557 - no-brainer refcounts for ts object.
558 - memory indices for dependency check are typedef'd and abstract'd.
559 - no-brainer refcounts for fi object, debug the mess.
560 - dump the header early in transaction, recreate fi before installing.
561 - start hiding availablePackage data/methods in rpmal.c/rpmal.h.
562 - add some dinky availablePackage methods.
563 - transaction.c: cleanly uncouple availablePackage from TFI_t.
564 - add header refcount annotations throughout.
565 - depends.c: availablePackage is (almost) opaque.
566 - invent some toy transactionElement iterators.
567 - create rpmDepSet constructors/destructors.
568 - create toy rpmDepSet iterators.
569 - rpmRangesOverlap renamed to dsCompare, add dsNotify method as well.
570 - depends.c: rpmDepSet is (almost) opaque, move to rpmds.[ch].
571 - rpmds: create dsProblem(), dsiGetDNEVR() retrieved DNEVR, not N.
572 - depends.h: hack around teIterator() et al from include for now.
573 - rpmds: move trigger dependencies into a rpmDepSet as well.
574 - rpmal: availablePackage is totally opaque, alKey with index replaces.
575 - fix: harmless typo in db3 chroot hack.
576 - fix: big-endian's with sizeof(time_t) != sizeof(int_32) mtime broken.
577 - fix: add Korean message catalogs (#54473).
578 - add RPHNPLATFORM and PLATFORM tags.
579 - linear search on added package provides is dumb.
580 - discarding entire signature header when using --addsign is dumb.
581 - rip out rpmDependencyConflict, replace with rpmProblem instead.
582 - no-brainer refcounts for rpmProblemSet object.
583 - header tag sets are per-transactionElement, not per-availablePackage.
584 - no-brainer refcounts for rpmDepSet and rpmFNSet objects.
585 - strip header tags for erased as well as installed transactionElements.
586 - common structure elements for unification of TFI_t and rpmFNSet.
587 - factor per-transactionElement data out of TFI_t through pointer ref.
588 - unify rpmFNSet into TFI_t.
589 - eliminate header reference in rpmtransAddPackage, use TFI_t data.
590 - commit to using rpmDepSet and TFI_t, not header.
591 - lclint rpmio fiddles.
592 - split file info tag sets into rpmfi.c.
593 - create toy TFI_t iterators.
594 - tweak overlapped file fingerprint retrieval for speed.
595 - transaction.c: use wrappers/iterators to access TFI_t.
596 - annotations to make a transactionElement opaque.
597 - use array of pointers rather than contiguous array for ts->order.
598 - methods to complete making transactionElement opaque.
599 - use TR_REMOVED relations as well as TR_ADDED for ordering.
600 - drop requirement that removed packages immediately follow added.
601 - hybrid chainsaw/presentation ordering algorithm.
602 - convert file md5sum's to binary on the fly, reducing memory footprint.
603 - header handling moved to librpmdb to avoid linkage loops.
604 - fix a couple dinky memory leaks.
605 - build with an internal zlib for now.
606 - protect brp-compress against /bin/ls output ambiguity (#56656,#56336).
607 - 3 madvise calls and a 16Mb mmapped buffer == ~5% install speedup. Wow.
608 - use db-4.0.14 final internally.
609 - 1st crack at making zlib rsync friendly.
610 - lclint-3.0.0.19 fiddles.
611 - solaris: translate i86pc to i386 (#57182).
612 - fix: %GNUconfigure breaks with single quotes (#57264).
613 - simple automake wrapper for zlib.
614 - add buildarch lines for hppa (#57728).
615 - sparc: make dbenv per-rpmdb, not per-dbi.
616 - handle lazy db open's in chroot with absolute path, not prefix strip.
617 - Depends should use CDB if configured.
618 - autodetect python 1.5/2.2.
619 - make rpm-perl package self-hosting (#57748).
620 - permit gpg/pgp/pgp5 execs to be reconfigured.
621 - fix: signing multiple times dinna work, discard immutable region.
622 - remove poptmodule.so for separate packaging.
623 - permit subset installs for %lang colored hardlink file sets.
624 - missing key(s) on keyring when verifying a signature is now an error.
625 - remove dependency whiteout.
626 - splint fiddles.
627 - ppc64 arch added (#58634,#58636).
628 - turn on auto-generated perl requirements (#58519, #58536, #58537).
629 - fix: %exclude functional (again).
630 - trap SIGILL for ppc64 inline asm voodoo fix from cross-dressed ppc32.
631 - rpm-perl: force numeric comparison on rpm version (#58882).
632 - fix: fancy hash fiddles if not a tty.
633 - fix: handle /.../ correctly in rpmCleanPath().
634 - legacy: configurable whiteout for known Red Hat dependency loops.
635 - perl.req: don't mis-generate dependencies like perl(::path/to/foo.pl).
636 - permit args to be hidden within %%__find_{requires,provides}.
637 - a couple more perl.{prov,req} fiddles.
638 - macro for %files, always include %defattr(), redhat config only.
639 - fix: drop header region when writing repackaged legacy header.
640 - bail on %files macro.
641 - transaction rollbacks are functional.
642 - generate index for pkgid (aka Sigmd5) tag, query/verify by pkgid.
643 - generate index for hdrid (aka Sha1header) tag, query/verify by hdrid.
644 - generate index for fileid (aka Filemd5s) tag, query/verify by fileid.
645 - query/verify by install transaction id.
646 - rpm-4.0.4 release candidate.
647 - add cpanflute2, another perl.req fiddle.
648 - make peace with gcc-3.1, remove compiler cruft.
649 - make peace with automake et al in 8.0, ugh.
650 - add payload uncompressed size to signature to avoid rewriting header.
651 - drill header sha1 into signature parallel to header+payload md5.
652 - mandatory "most effective" signature check on query/verify/install.
653 - don't bother adding empty filemd's to index.
654 - add Pubkey index, using signer id as binary key.
655 - display pubkeys in hex when debugging db access.
656 - retrieve pubkey(s) from rpmdb, not from detached signature file.
657 - reapply Berkeley DB patch #4491.
658 - add header DSA signature.
659 - add header RSA signature (untested, disabled for now).
660 - don't bother with signing check if 16 bits of hash don't match.
661 - only V3 signatures for now.
662 - wire --nodigest/--nosignature options to checksig/query/verify modes.