5d45a7ec172541661241f687f2556129368b16e5
[platform/upstream/rpm.git] / rpm.spec
1 Summary: The Red Hat package management system.
2 Name: rpm
3 %define version 2.92
4 Version: %{version}
5 Release: 12
6 Group: System Environment/Base
7 Source: ftp://ftp.rpm.org/pub/rpm/dist/rpm-2.5.x/rpm-%{version}.tar.gz
8 Copyright: GPL
9 BuildRoot: /var/tmp/rpm-%{version}-root
10 Conflicts: patch < 2.5
11
12 %description
13 The Red Hat Package Manager (RPM) is a powerful command line driven
14 package management system capable of installing, uninstalling,
15 verifying, querying, and updating software packages.  Each software
16 package consists of an archive of files along with information about
17 the package like its version, a description, etc.
18
19 %package devel
20 Summary: Development files for applications which will manipulate RPM packages.
21 Group: Development/Libraries
22
23 %description devel
24 This package contains the RPM C library and header files.  These
25 development files will simplify the process of writing programs
26 which manipulate RPM packages and databases and are intended to make
27 it easier to create graphical package managers or any other tools
28 that need an intimate knowledge of RPM packages in order to function.
29
30 This package should be installed if you want to develop programs that
31 will manipulate RPM packages and databases.
32
33 %prep
34 %setup -q
35
36 %build
37 CFLAGS="$RPM_OPT_FLAGS" ./configure --prefix=/usr --disable-shared
38 make
39
40 %install
41 rm -rf $RPM_BUILD_ROOT
42 mkdir -p $RPM_BUILD_ROOT/usr/lib
43
44 mkdir -p $RPM_BUILD_ROOT/usr/src/redhat/SOURCES
45 mkdir -p $RPM_BUILD_ROOT/usr/src/redhat/SPECS
46 mkdir -p $RPM_BUILD_ROOT/usr/src/redhat/SRPMS
47 mkdir -p $RPM_BUILD_ROOT/usr/src/redhat/BUILD
48 mkdir -p $RPM_BUILD_ROOT/usr/src/redhat/RPMS/${RPM_ARCH}
49 mkdir -p $RPM_BUILD_ROOT/usr/src/redhat/RPMS/noarch
50
51 make DESTDIR="$RPM_BUILD_ROOT" install
52
53 %clean
54 rm -rf $RPM_BUILD_ROOT
55
56 %post
57 /bin/rpm --initdb
58
59 %files
60 %defattr(-,root,root)
61 %doc RPM-PGP-KEY CHANGES GROUPS
62 %doc docs/*
63 /bin/rpm
64 /usr/bin/rpm2cpio
65 /usr/bin/gendiff
66 /usr/man/man8/rpm.8
67 /usr/man/man8/rpm2cpio.8
68 /usr/lib/rpm
69 /usr/lib/rpmrc
70 /usr/lib/rpmpopt
71 %dir /usr/src/redhat
72 %dir /usr/src/redhat/BUILD
73 %dir /usr/src/redhat/SPECS
74 %dir /usr/src/redhat/SOURCES
75 %dir /usr/src/redhat/SRPMS
76 %dir /usr/src/redhat/RPMS
77 /usr/src/redhat/RPMS/*
78 /usr/share/locale/*/LC_MESSAGES/rpm.mo
79
80 %files devel
81 %defattr(-,root,root)
82 /usr/include/rpm
83 /usr/lib/librpm.a