nfc-manager-neard: update recipe
[scm/bb/meta-tizen.git] / recipes-core / dbus / dbus-test_1.6.18.bb
1 SUMMARY = "D-Bus test package (for D-bus functionality testing only)"
2 HOMEPAGE = "http://dbus.freedesktop.org"
3 SECTION = "base"
4 LICENSE = "AFL-2 | GPLv2+"
5 LIC_FILES_CHKSUM = "file://COPYING;md5=10dded3b58148f3f1fd804b26354af3e \
6                     file://dbus/dbus.h;beginline=6;endline=20;md5=7755c9d7abccd5dbd25a6a974538bb3c"
7
8 DEPENDS = "python-pygobject dbus dbus-glib"
9
10 RDEPENDS_${PN} += "make"
11 RDEPENDS_${PN}-dev = ""
12
13 SRC_URI = "http://dbus.freedesktop.org/releases/dbus/dbus-${PV}.tar.gz \
14            file://tmpdir.patch \
15            file://ptest.patch \
16            file://dbus-1.init  \
17            file://run-ptest \
18            file://python-config.patch \
19            file://clear-guid_from_server-if-send_negotiate_unix_f.patch \
20            "
21
22 SRC_URI[md5sum] = "b02e9c95027a416987b81f9893831061"
23 SRC_URI[sha256sum] = "7085a0895a9eb11a952394cdbea6d8b4358e17cb991fed0e8fb85e2b9e686dcd"
24
25 S="${WORKDIR}/dbus-${PV}"
26 FILESPATH = "${FILE_DIRNAME}/dbus"
27
28 inherit autotools pkgconfig gettext ptest
29
30 EXTRA_OECONF_X = "${@bb.utils.contains('DISTRO_FEATURES', 'x11', '--with-x', '--without-x', d)}"
31 EXTRA_OECONF_X_class-native = "--without-x"
32
33 EXTRA_OECONF = "--enable-tests \
34                 --enable-modular-tests \
35                 --enable-installed-tests \
36                 --enable-checks \
37                 --enable-asserts \
38                 --enable-verbose-mode \
39                 --disable-xml-docs \
40                 --disable-doxygen-docs \
41                 --disable-libaudit \
42                 --with-xml=expat \
43                 --disable-systemd \
44                 --without-systemdsystemunitdir \
45                 --with-dbus-test-dir=${PTEST_PATH} \
46                 ${EXTRA_OECONF_X}"
47
48 do_install() {
49 }
50
51 do_install_ptest() {
52     find ${D}${PTEST_PATH} -name Makefile | xargs sed -i 's/^Makefile:/_Makefile:/'
53 }