fix update
[scm/bb/tizen.git] / proto-meta-Tizen_generic / specfile-initial / smack / packaging / smack.spec
1 Name:       smack
2 Version:    1.0.3.1
3 Release:    1
4 Summary:    Selection of tools for developers working with Smack
5 Group:      Security/Access Control
6 License:    LGPL-2.1
7 URL:        https://github.com/smack-team/smack
8 Source0:    %{name}-%{version}.tar.gz
9 Source1001:     smack.manifest
10 BuildRequires: automake
11 BuildRequires: autoconf
12 BuildRequires: libtool
13
14 %description
15 Tools provided to load and unload rules from the kernel and query the policy
16
17 %package devel
18 Summary:    Development headers and libs for libsmack
19 Group:      Development/Libraries
20 Requires:   libsmack = %{version}
21
22 %description devel
23 Standard header files for use when developing Smack enabled applications
24
25 %package -n libsmack
26 Summary:    Library allows applications to work with Smack
27 Group:      Security/Access Control
28
29 %description -n libsmack
30 Library allows applications to work with Smack.
31
32 %prep
33 %setup -q
34 cp %{SOURCE1001} .
35
36 %build
37 %reconfigure --with-systemdsystemunitdir=%{_unitdir}
38
39 make %{?_smp_mflags}
40
41 %install
42 %make_install
43 install -d %{buildroot}%{_sysconfdir}/smack/accesses.d
44 install -d %{buildroot}%{_sysconfdir}/smack/cipso.d
45 install -d %{buildroot}%{_sysconfdir}/smack/netlabel.d
46
47 %post -p /sbin/ldconfig -n libsmack
48
49 %postun -p /sbin/ldconfig -n libsmack
50
51 %docs_package
52
53 %files -n libsmack
54 %manifest %{name}.manifest
55 %defattr(644,root,root,755)
56 %license COPYING
57 %{_libdir}/libsmack.so.*
58
59 %files devel
60 %manifest %{name}.manifest
61 %defattr(644,root,root,755)
62 %{_includedir}/sys/smack.h
63 %{_libdir}/libsmack.so
64 %{_libdir}/pkgconfig/libsmack.pc
65
66 %files
67 %manifest %{name}.manifest
68 %defattr(644,root,root,755)
69 %{_sysconfdir}/smack
70 %{_sysconfdir}/smack/accesses.d
71 %{_sysconfdir}/smack/cipso.d
72 %{_sysconfdir}/smack/netlabel.d
73 %attr(755,root,root) %{_bindir}/*
74