tizen-3.0-ivi_20150201.3_atom.xml: archive manifest file
[scm/bb/tizen.git] / proto-meta-Tizen_generic / specfile-initial / libwebsockets / packaging / libwebsockets.spec
1 Name:       libwebsockets
2 Summary:    WebSocket Library
3 Version:    1.2
4 Release:    0
5 Group:      System/Libraries
6 License:    LGPL-2.1
7 URL:        http://git.warmcat.com/cgi-bin/cgit/libwebsockets/
8 Source0:    %{name}-%{version}.tar.bz2
9 Source1001: %{name}.manifest
10 Requires(post):   /sbin/ldconfig
11 Requires(postun): /sbin/ldconfig
12 BuildRequires:    zlib-devel
13 BuildRequires:    openssl-devel
14 BuildRequires:    cmake
15 BuildRequires:    pkgconfig(libsystemd-daemon)
16
17 %description
18 C Websockets Server Library
19
20 %package devel
21 Summary:    Development files for %{name}
22 Group:      Development/Libraries
23 Requires:   %{name} = %{version}-%{release}
24
25 %description devel
26 Development files needed for building websocket clients and servers
27
28 %prep
29 %setup -q -n %{name}-%{version}
30 cp %{SOURCE1001} .
31
32
33 %build
34
35 %cmake -DWITH_SSL=On -DWITH_SD_DAEMON=ON
36
37 %__make %{?_smp_mflags}
38
39 %install
40 rm -rf %{buildroot}
41 %make_install
42
43 %post -p /sbin/ldconfig
44
45 %postun -p /sbin/ldconfig
46
47 %files
48 %defattr(-,root,root,-)
49 %manifest %{name}.manifest
50 %{_bindir}/libwebsockets*
51 %{_libdir}/libwebsockets*.so.*
52 %{_datadir}/libwebsockets-test-server/*
53
54 %files devel
55 %defattr(-,root,root,-)
56 %manifest %{name}.manifest
57 %{_includedir}/libwebsockets.h
58 %{_libdir}/libwebsockets.so
59 %{_libdir}/pkgconfig/*