Remove hardcoded target.
[scm/bb/tizen.git] / proto-meta-Tizen_generic / specfile-initial / elementary / packaging / elementary.spec
1 %bcond_with wayland
2 %bcond_with x
3 Name:           elementary
4 Version:        1.7.8
5 Release:        0 
6 License:        LGPL-2.1+
7 Summary:        EFL toolkit for small touchscreens
8 Url:            http://trac.enlightenment.org/e/wiki/Elementary
9 Group:          Graphics/EFL
10 Source0:        elementary-%{version}.tar.bz2
11 Source1001:     elementary.manifest
12 BuildRequires:  doxygen
13 BuildRequires:  gettext
14 BuildRequires:  pkgconfig(ecore)
15 BuildRequires:  pkgconfig(ecore-evas)
16 BuildRequires:  pkgconfig(ecore-fb)
17 BuildRequires:  pkgconfig(ecore-file)
18 BuildRequires:  pkgconfig(ecore-imf)
19 %if %{with wayland}
20 BuildRequires:  pkgconfig(ecore-wayland)
21 %endif
22 %if %{with x}
23 BuildRequires:  pkgconfig(ecore-x)
24 BuildRequires:  pkgconfig(x11)
25 %endif
26 BuildRequires:  pkgconfig(edbus)
27 BuildRequires:  pkgconfig(edje)
28 BuildRequires:  pkgconfig(eet)
29 BuildRequires:  pkgconfig(efreet)
30 BuildRequires:  pkgconfig(eina)
31 BuildRequires:  pkgconfig(evas)
32 BuildRequires:  pkgconfig(emotion)
33 BuildRequires:  pkgconfig(ethumb_client)
34 BuildRequires:  eet-tools
35 BuildRequires:  python-devel
36
37 %description
38 Elementary is a widget set. It is a new-style of widget set much more canvas
39 object based than anything else. Why not ETK? Why not EWL? Well they both
40 tend to veer away from the core of Evas, Ecore and Edje a lot to build their
41 own worlds. Also I wanted something focused on embedded devices -
42 specifically small touchscreens. Unlike GTK+ and Qt, 75% of the "widget set"
43 is already embodied in a common core - Ecore, Edje, Evas etc. So this
44 fine-grained library splitting means all of this is shared, just a new
45 widget "personality" is on top. And that is... Elementary, my dear watson.
46 Elementary.
47
48 %package examples
49 Summary:   EFL elementary examples
50
51 %description examples
52 EFL elementary examples
53
54 %package tools
55 Summary:   EFL elementary configuration and test apps
56
57 %description tools
58 EFL elementary configuration and test apps
59
60 %package devel
61 Summary:        Development components for the elementary package
62 Group:          Development/Libraries
63 Requires:       %{name} = %{version}
64
65 %description devel
66 Development files for elementary
67
68 %prep
69 %setup -q
70 cp %{SOURCE1001} .
71
72 %build
73
74 %reconfigure --disable-static \
75 %if %{with wayland}
76          --enable-ecore-wayland \
77 %endif
78 %if !%{with x}
79          --disable-ecore-x \
80 %endif
81          --enable-build-examples
82
83 make %{?_smp_mflags}
84
85 %install
86 %make_install
87
88 %find_lang %{name}
89
90 %post -p /sbin/ldconfig
91
92 %postun -p /sbin/ldconfig
93
94 %lang_package
95
96 %files 
97 %manifest %{name}.manifest
98 %defattr(-,root,root,-)
99 %license COPYING
100 %{_bindir}/elementary_quicklaunch
101 %{_bindir}/elementary_run
102 %{_libdir}/edje/*
103 %{_libdir}/elementary/modules/*
104 %{_libdir}/*.so.*
105 %{_datadir}/elementary/*
106 %{_datadir}/icons/elementary.png
107
108 %files examples
109 %defattr(-,root,root,-)
110 %{_libdir}/elementary/examples/*
111
112 %files tools
113 %defattr(-,root,root,-)
114 %{_datadir}/applications/*
115 %{_bindir}/elementary_config
116 %{_bindir}/elementary_test*
117
118 %files devel
119 %manifest %{name}.manifest
120 %defattr(-,root,root,-)
121 %{_includedir}/elementary-1/*.h
122 %{_libdir}/*.so
123 %{_libdir}/pkgconfig/*.pc
124
125 %changelog