Update init spec files
[scm/bb/tizen.git] / proto-meta-Tizen_generic / specfile-initial / elementary / packaging / elementary.spec
1 %define dbus_unavailable 1
2
3 %bcond_with wayland
4 %bcond_with x
5 Name:           elementary
6 Version:        1.9.3
7 Release:        0
8 License:        LGPL-2.1+
9 Summary:        EFL toolkit for small touchscreens
10 Url:            http://trac.enlightenment.org/e/wiki/Elementary
11 Group:          Graphics/EFL
12 Source0:        elementary-%{version}.tar.bz2
13 Source1001:     elementary.manifest
14 BuildRequires:  doxygen
15 BuildRequires:  gettext-devel
16 BuildRequires:  pkgconfig(ecore)
17 BuildRequires:  pkgconfig(ecore-evas)
18 BuildRequires:  pkgconfig(ecore-file)
19 BuildRequires:  pkgconfig(ecore-imf)
20
21 %if %{with wayland}
22 BuildRequires:  pkgconfig(ecore-wayland)
23 %endif
24
25 %if %{with x}
26 BuildRequires:  pkgconfig(ecore-x)
27 BuildRequires:  pkgconfig(x11)
28 %endif
29
30 %if !%{with x}
31 %if !%{with wayland}
32 BuildRequires:  pkgconfig(ecore-fb)
33 %endif
34 %endif
35
36 BuildRequires:  pkgconfig(edbus)
37 BuildRequires:  pkgconfig(edje)
38 BuildRequires:  pkgconfig(eet)
39 BuildRequires:  pkgconfig(efreet)
40 BuildRequires:  pkgconfig(eina)
41 BuildRequires:  pkgconfig(evas)
42 BuildRequires:  pkgconfig(ethumb)
43 BuildRequires:  pkgconfig(emotion)
44 BuildRequires:  eet-tools
45 BuildRequires:  python-devel
46 Recommends:     %{name}-locale = %{version}
47
48 %description
49 Elementary is a widget set. It is a new-style of widget set much more canvas
50 object based than anything else. Why not ETK? Why not EWL? Well they both
51 tend to veer away from the core of Evas, Ecore and Edje a lot to build their
52 own worlds. Also I wanted something focused on embedded devices -
53 specifically small touchscreens. Unlike GTK+ and Qt, 75% of the "widget set"
54 is already embodied in a common core - Ecore, Edje, Evas etc. So this
55 fine-grained library splitting means all of this is shared, just a new
56 widget "personality" is on top. And that is... Elementary, my dear watson.
57 Elementary.
58
59 %package examples
60 Summary:   EFL elementary examples
61
62 %description examples
63 EFL elementary examples
64
65 %package tools
66 Summary:   EFL elementary configuration and test apps
67
68 %description tools
69 EFL elementary configuration and test apps
70
71 %package devel
72 Summary:        Development components for the elementary package
73 Group:          Development/Libraries
74 Requires:       %{name} = %{version}
75
76 %description devel
77 Development files for elementary
78
79 %prep
80 %setup -q
81 cp %{SOURCE1001} .
82
83 %build
84
85 %autogen --disable-static \
86 %if %{with wayland}
87          --enable-ecore-wayland \
88 %endif
89 %if !%{with x}
90          --disable-ecore-x \
91 %endif
92 %if %dbus_unavailable
93          --disable-build-examples \
94 %else
95          --enable-build-examples \
96 %endif
97     #eol
98
99 make %{?_smp_mflags}
100
101 %install
102 %make_install
103
104 %find_lang %{name}
105
106 %post -p /sbin/ldconfig
107
108 %postun -p /sbin/ldconfig
109
110 %lang_package
111
112 %files
113 %manifest %{name}.manifest
114 %defattr(-,root,root,-)
115 %license COPYING
116 %{_bindir}/elementary_quicklaunch
117 %{_bindir}/elementary_run
118 %{_libdir}/edje/*
119 %{_libdir}/elementary/modules/*
120 %{_libdir}/*.so.*
121 %{_datadir}/elementary/*
122 %{_datadir}/icons/elementary.png
123
124 %if ! %dbus_unavailable
125 %files examples
126 %manifest %{name}.manifest
127 %defattr(-,root,root,-)
128 %{_libdir}/elementary/examples/*
129 %endif
130
131 %files tools
132 %manifest %{name}.manifest
133 %defattr(-,root,root,-)
134 %{_datadir}/applications/*
135 %{_bindir}/elementary_config
136 %{_bindir}/elementary_test*
137 %{_bindir}/elementary_codegen
138 %{_bindir}/elm_prefs_cc
139
140 %files devel
141 %manifest %{name}.manifest
142 %defattr(-,root,root,-)
143 %{_includedir}/elementary-1/*.h
144 %{_libdir}/*.so
145 %{_libdir}/pkgconfig/*.pc
146 %{_libdir}/cmake/Elementary/ElementaryConfig.cmake
147 %{_libdir}/cmake/Elementary/ElementaryConfigVersion.cmake
148
149 %changelog