Add new spec init for ivi.
[scm/bb/tizen.git] / proto-meta-Tizen_generic / specfile-initial / dlt-daemon / packaging / dlt-daemon.spec
1 Name:             dlt
2 License:          MPL-2.0
3 Group:            Automotive/GENIVI
4 Summary:          GENIVI Diagnostic Log and Trace
5 Version:          2.9.1
6 Release:          1
7 Source:           %{name}-%{version}.tar.bz2
8 BuildRequires:    cmake
9 BuildRequires:    pkgconfig(zlib)
10 BuildRequires:    pkgconfig(libsystemd-journal)
11 Requires(post):   /sbin/ldconfig
12 Requires(postun): /sbin/ldconfig
13
14 %description
15 GENIVI Diagnostic Log and Tracing Daemon and Tools
16
17 %package daemon
18 Summary:        GENIVI DLT Daemon
19
20 %description daemon
21 GENIVI Diagnostic Log and Tracing Daemon
22
23 %package bin
24 Summary:        GENIVI DLT utility binaries
25
26 %description bin
27 GENIVI DLT utility binaries
28
29 %package test
30 Summary:        GENIVI DLT test binaries
31
32 %description test
33 GENIVI DLT test binaries
34
35 %package -n libdlt
36 Summary:        GENIVI DLT library
37
38 %description -n libdlt
39 GENIVI DLT library
40
41 %package devel
42 Summary:         Automotive DLT Development Package
43 Requires:        libdlt = %{version}-%{release}
44
45 %description devel
46 Files needed for developing against the Automotive DLT
47
48 %prep
49 %setup -q -n %{name}-%{version}
50
51 %build
52 mkdir build
53 cd build
54
55 cmake -DWITH_SYSTEMD=ON -DWITH_SYSTEMD_JOURNAL=ON \
56       -DWITH_MAN=OFF -DWITH_DLT_EXAMPLES=OFF ..
57 make %{?jobs:-j %jobs}
58
59 %install
60 rm -rf "$RPM_BUILD_ROOT"
61 cd build
62 make install DESTDIR=$RPM_BUILD_ROOT
63
64 %post -n libdlt -p /sbin/ldconfig
65
66 %postun -n libdlt -p /sbin/ldconfig
67
68 %clean
69 rm -rf "$RPM_BUILD_ROOT"
70
71 %files daemon
72 %defattr(-,root,root,-)
73 %{_bindir}/dlt-daemon
74 %config %{_sysconfdir}/dlt.conf
75 %{_prefix}/lib/systemd/system/dlt.service
76
77 %files test
78 %defattr(-,root,root,-)
79 %{_bindir}/dlt-test*
80 %{_datadir}/dlt-filetransfer/*
81
82 %files bin
83 %defattr(-,root,root,-)
84 %{_bindir}/dlt-adaptor*
85 %{_bindir}/dlt-convert
86 %{_bindir}/dlt-receive
87 %{_bindir}/dlt-system
88 %{_bindir}/dlt-control
89 %config %{_sysconfdir}/dlt-system.conf
90 %{_prefix}/lib/systemd/system/dlt-adaptor-udp.service
91 %{_prefix}/lib/systemd/system/dlt-receive.service
92 %{_prefix}/lib/systemd/system/dlt-system.service
93
94 %files -n libdlt
95 %defattr(-,root,root,-)
96 %{_libdir}/*so.*
97
98 %files devel
99 %defattr(-,root,root,-)
100 %{_includedir}/dlt/*
101 %{_libdir}/*.so
102 %{_libdir}/pkgconfig/*.pc