Updated with Tizen:Base source codes
[external/procps.git] / procps.spec
1 URL: http://procps.sf.net/
2 Summary: System and process monitoring utilities
3 Name: procps
4 %define major_version 3
5 %define minor_version 2
6 %define revision 8
7 %define version %{major_version}.%{minor_version}.%{revision}
8 Version: %{version}
9 Release: 1
10 License: LGPL, GPL, BSD-like
11 Group: Applications/System
12 Source: http://procps.sf.net/procps-%{version}.tar.gz
13 BuildRoot: %{_tmppath}/procps-root
14 Packager: <procps-feedback@lists.sf.net>
15
16 %description
17 The procps package contains a set of system utilities which provide
18 system information.  Procps includes ps, free, sysctl, skill, snice,
19 tload, top, uptime, vmstat, w, and watch. You need some of these.
20
21 %prep
22 %setup
23
24 %build
25 make SKIP="/bin/kill /usr/share/man/man1/kill.1" CFLAGS="$RPM_OPT_FLAGS"
26
27 %install
28 rm -rf $RPM_BUILD_ROOT
29 make SKIP="/bin/kill /usr/share/man/man1/kill.1" DESTDIR=$RPM_BUILD_ROOT ldconfig=echo install="install -D" lib="$RPM_BUILD_ROOT/%{_lib}/" install
30
31 %clean
32 rm -rf $RPM_BUILD_ROOT
33
34 %post
35 # add libproc to the cache
36 /sbin/ldconfig
37
38 %files
39 %defattr(0644,root,root,755)
40 %doc NEWS BUGS TODO COPYING COPYING.LIB README.top README AUTHORS sysctl.conf
41 %attr(555,root,root) /lib*/libproc*.so*
42 %attr(555,root,root) /bin/*
43 %attr(555,root,root) /sbin/*
44 %attr(555,root,root) /usr/bin/*
45
46 %attr(0644,root,root) /usr/share/man/man1/*
47 %attr(0644,root,root) /usr/share/man/man5/*
48 %attr(0644,root,root) /usr/share/man/man8/*
49
50 %changelog
51 * Fri Apr 14 09:23:45 PDT 2006  Jesse Brandeburg <jesse.brandeburg@in...>
52 - fix missing trailing slash in %install to fix builds on x86_64