add packaging
[platform/upstream/zypp-plugin.git] / packaging / zypp-plugin.spec
1 #
2 # spec file for package zypp-plugin
3 #
4 # Copyright (c) 2011-2012 SUSE LINUX Products GmbH, Nuernberg, Germany.
5 #
6 # All modifications and additions to the file contributed by third parties
7 # remain the property of their copyright owners, unless otherwise agreed
8 # upon. The license for this file, and modifications and additions to the
9 # file, is the same license as for the pristine package itself (unless the
10 # license for the pristine package is not an Open Source License, in which
11 # case the license is the MIT License). An "Open Source License" is a
12 # license that conforms to the Open Source Definition (Version 1.9)
13 # published by the Open Source Initiative.
14 #
15 Name:           zypp-plugin
16 Version:        0.3
17 Release:        0
18 Group:          System/Packages
19 License:        GPL-2.0
20 Url:            https://gitorious.org/opensuse/zypp-plugin
21 Summary:        Helper that makes writing ZYpp plugins easier
22 Source0:        %{name}-%{version}.tar.bz2
23
24 # Actually libzypp(plugin) should be required. Unfortunately the corresponing
25 # provides was introduced to late for SUSE Manager/SLE-11-SP1. We do not want to
26 # enforce libzypp update to satisfy this, so the Requires should saty disabled,
27 # until libzypp on SUSE Manager/SLE-11-SP1 was updated and provides libzypp(plugin).
28 #Requires:      libzypp(plugin)
29 BuildRequires:  python-devel
30 Requires:       python
31
32 %description
33 Empty main package. Helper for different languages reside in subpackages.
34
35 %package python
36 Group:          System/Packages
37 License:        GPL-2.0
38 Summary:        Helper that makes writing ZYpp plugins in python easier
39
40 %description python
41 This API allows writing ZYpp plugins by just subclassing from a python class
42 and implementing the commands you want to respond to as python methods.
43
44 %prep
45 %setup -q -n zypp-plugin
46
47 %build
48
49 %install
50 %{__mkdir_p} %{buildroot}%{py_sitedir}
51 %{__install} python/zypp_plugin.py %{buildroot}%{py_sitedir}/zypp_plugin.py
52
53 %files python
54 %defattr(-,root,root)
55 %{py_sitedir}/zypp_plugin.py