Release 0.0.3
[platform/core/security/yaca.git] / packaging / yaca.spec
1 Name:               yaca
2 Version:            0.0.3
3 Release:            0
4 Source0:            %{name}-%{version}.tar.gz
5 License:            Apache-2.0
6 Group:              Security/Other
7 Summary:            Yet Another Crypto API
8 BuildRequires:      cmake
9 BuildRequires:      pkgconfig(capi-base-common)
10 BuildRequires:      pkgconfig(openssl)
11 Requires(post):     /sbin/ldconfig
12 Requires(postun):   /sbin/ldconfig
13
14 %description
15 The package provides Yet Another Crypto API.
16
17 %post -p /sbin/ldconfig
18
19 %postun -p /sbin/ldconfig
20
21 %files
22 %license LICENSE
23 %manifest yaca.manifest
24 %{_libdir}/libyaca.so.0
25 %{_libdir}/libyaca.so.%{version}
26
27 %prep
28 %setup -q
29
30 %build
31 %{!?build_type:%define build_type "RELEASE"}
32
33 %cmake . -DCMAKE_BUILD_TYPE=%{build_type}
34 make -k %{?jobs:-j%jobs}
35
36 %install
37 %make_install
38
39 %clean
40 rm -rf %{buildroot}
41
42 ## Devel Package ###############################################################
43 %package devel
44 Summary:        Yet Another Crypto API development files
45 Group:          Security/Other
46 Requires:       yaca = %{version}-%{release}
47
48 %description devel
49 The package provides Yet Another Crypto API development files.
50
51 %files devel
52 %{_libdir}/libyaca.so
53 %{_includedir}/yaca
54 %{_libdir}/pkgconfig/yaca.pc
55
56 ## Examples Package ############################################################
57 %package examples
58 Summary:        Yet Another Crypto API example files
59 Group:          Security/Other
60 Requires:       yaca = %{version}-%{release}
61
62 %description examples
63 The package provides Yet Another Crypto API example files.
64
65 %files examples
66 %{_bindir}/yaca-example*
67 %{_datadir}/%{name}/examples