Replace spaces with tabs
[platform/core/security/yaca.git] / packaging / yaca.spec
1 Name:               yaca
2 Version:            0.0.2
3 Release:            0
4 Source0:            %{name}-%{version}.tar.gz
5 License:            Apache-2.0
6 Group:              Security/Other
7 Summary:            Yet Another Crypto API
8 BuildRequires:      cmake
9 BuildRequires:      pkgconfig(capi-base-common)
10 BuildRequires:      pkgconfig(openssl)
11 Requires(post):     /sbin/ldconfig
12 Requires(postun):   /sbin/ldconfig
13
14 %description
15 The package provides Yet Another Crypto API.
16
17 %post -p /sbin/ldconfig
18
19 %postun -p /sbin/ldconfig
20
21 %files
22 %manifest yaca.manifest
23 %{_libdir}/libyaca.so.0
24 %{_libdir}/libyaca.so.%{version}
25
26 %prep
27 %setup -q
28
29 %build
30 %{!?build_type:%define build_type "RELEASE"}
31
32 %cmake . -DCMAKE_BUILD_TYPE=%{build_type}
33 make -k %{?jobs:-j%jobs}
34
35 %install
36 %make_install
37
38 %clean
39 rm -rf %{buildroot}
40
41 ## Devel Package ###############################################################
42 %package devel
43 Summary:        Yet Another Crypto API development files
44 Group:          Security/Other
45 Requires:       yaca = %{version}-%{release}
46
47 %description devel
48 The package provides Yet Another Crypto API development files.
49
50 %files devel
51 %{_libdir}/libyaca.so
52 %{_includedir}/yaca
53 %{_libdir}/pkgconfig/yaca.pc
54
55 ## Examples Package ############################################################
56 %package examples
57 Summary:        Yet Another Crypto API example files
58 Group:          Security/Other
59 Requires:       yaca = %{version}-%{release}
60
61 %description examples
62 The package provides Yet Another Crypto API example files.
63
64 %files examples
65 %{_bindir}/yaca-example*
66 %{_datadir}/%{name}/examples