initial commit
[profile/ivi/xterm.git] / packaging / xterm.spec
1 %define x11_app_defaults_dir %(pkg-config --variable appdefaultdir xt)
2
3 Name:       xterm
4 Summary:    Terminal emulator for the X Window System
5 Version:    268
6 Release:    2.5
7 Group:      System/X
8 License:    MIT
9 URL:        http://dickey.his.com/xterm
10 Source0:    ftp://invisible-island.net/xterm/%{name}-%{version}.tgz
11 Source1:    ftp://invisible-island.net/xterm/16colors.txt
12 Source2:    xterm.desktop
13 Source3:    failsafe.desktop
14 Patch0:     xterm-261-resources.patch
15 Patch1:     xterm-256-man-page_paths.patch
16 Patch2:     buildfix.patch
17 BuildRequires:  pkgconfig(xft)
18 BuildRequires:  pkgconfig(xaw7)
19 BuildRequires:  pkgconfig(xext)
20 BuildRequires:  pkgconfig(ncurses)
21 BuildRequires:  pkgconfig(xkbfile)
22 BuildRequires:  imake
23 BuildRequires:  desktop-file-utils
24
25
26 %description
27 The xterm program is a terminal emulator for the X Window System. It
28 provides DEC VT102 and Tektronix 4014 compatible terminals for
29 programs that can not use the window system directly.
30
31
32 %prep
33 %setup -q -n %{name}-%{version}
34
35 # xterm-261-resources.patch
36 %patch0 -p1
37 # xterm-256-man-page_paths.patch
38 %patch1 -p1
39 # buildfix.patch
40 %patch2 -p1
41
42 %build
43
44 %configure --disable-static \
45     --with-app-defaults=%{x11_app_defaults_dir} \
46     --enable-256-color \
47     --enable-exec-xterm \
48     --enable-luit \
49     --enable-warnings \
50     --enable-wide-chars \
51     --with-tty-group=tty \
52     --disable-full-tgetent
53
54 make %{?jobs:-j%jobs}
55
56 %install
57 rm -rf %{buildroot}
58 %make_install
59
60
61 mkdir -p %{buildroot}%{_datadir}/applications/
62 install -m 644 %{SOURCE2} %{buildroot}%{_datadir}/applications/
63 mkdir -p %{buildroot}%{_datadir}/xsessions/
64 install -m 644 %{SOURCE3} %{buildroot}%{_datadir}/xsessions/
65
66 cp -fp %{SOURCE1} 16colors.txt
67
68 desktop-file-install --delete-original       \
69   --dir %{buildroot}%{_datadir}/applications             \
70    %{buildroot}%{_datadir}/applications/*.desktop
71
72
73 %files
74 %defattr(-,root,root,-)
75 %doc xterm.log.html ctlseqs.txt 16colors.txt README.i18n
76 %{_bindir}/xterm
77 %{_bindir}/koi8rxterm
78 %{_bindir}/resize
79 %{_bindir}/uxterm
80 %doc %{_mandir}/man1/koi8rxterm.1*
81 %doc %{_mandir}/man1/resize.1*
82 %doc %{_mandir}/man1/uxterm.1*
83 %doc %{_mandir}/man1/xterm.1*
84 %{_datadir}/applications/xterm.desktop
85 %{_datadir}/xsessions/failsafe.desktop
86 %{_datadir}/pixmaps/*
87 %{x11_app_defaults_dir}/KOI8RXTerm*
88 %{x11_app_defaults_dir}/UXTerm*
89 %{x11_app_defaults_dir}/XTerm*
90
91