initial commit
[profile/ivi/xorg-x11-xinit.git] / packaging / xorg-x11-xinit.spec
1 %define pkgname xinit
2
3 Summary:   X.Org X11 X Window System xinit startup scripts
4 Name:      xorg-x11-%{pkgname}
5 Version:   1.1.0
6 Release:   1
7 License:   MIT/X11
8 Group:     User Interface/X
9 URL:       http://www.x.org
10 Source0:   %{name}-%{version}.tar.bz2
11
12 BuildRequires: pkgconfig
13 BuildRequires: pkgconfig(x11)
14 BuildRequires: autoconf
15 BuildRequires: automake
16 BuildRequires: libtool
17 BuildRequires: xorg-x11-util-macros
18 Requires: xauth
19
20 %description
21 X.Org X11 X Window System xinit startup scripts
22
23 %prep
24 %setup -q -n %{name}-%{version}
25
26 %build
27 export CFLAGS="${CFLAGS} -D_F_EXIT_AFTER_XORG_AND_XCLIENT_LAUNCHED_"
28 ./autogen.sh
29 ./configure --prefix=%{_prefix}
30
31 make %{?jobs:-j%jobs}
32
33
34 %install
35 rm -rf $RPM_BUILD_ROOT
36 make install DESTDIR=$RPM_BUILD_ROOT
37
38
39
40 %remove_docs
41
42 %clean
43 rm -rf $RPM_BUILD_ROOT
44
45 %files
46 %{_bindir}/xinit
47 %{_libdir}/X11/xinit/xinitrc
48