upload tizen2.0 source
[framework/uifw/xorg/app/xinit.git] / packaging / xorg-x11-xinit.spec
1 %define _unpackaged_files_terminate_build 0 
2
3 Summary:   X.Org X11 X Window System xinit startup scripts
4 Name:      xorg-x11-xinit
5 Version:   1.3.2
6 Release:   5
7 License:   MIT
8 Group:     User Interface/X
9 URL:       http://www.x.org
10
11 Source: %{name}-%{version}.tar.gz
12 #Source0:  ftp://ftp.x.org/pub/individual/app/%{pkgname}-%{version}.tar.bz2
13 #Source10: xinitrc-common
14 #Source11: xinitrc
15 #Source12: Xclients
16 #Source13: Xmodmap
17 #Source14: Xresources
18 # NOTE: Xsession is used by xdm/kdm/gdm and possibly others, so we keep it
19 #       here instead of the xdm package.
20 #Source16: Xsession
21 #Source17: localuser.sh
22 #Source18: xinit-compat.desktop
23 #Source19: xinit-compat
24
25 # Fedora specific patches
26
27 #Patch1: xinit-1.0.2-client-session.patch
28 #Patch3: xinit-1.0.9-unset.patch
29
30 BuildRequires: pkgconfig
31 BuildRequires: libX11-devel
32 BuildRequires: autoconf
33 BuildRequires: automake
34 BuildRequires: dbus-devel
35 BuildRequires: libtool
36 BuildRequires: xorg-x11-xutils-dev
37 # NOTE: startx needs xauth in order to run, but that is not picked up
38 #       automatically by rpm.  (Bug #173684)
39 #Requires: xorg-x11-xauth
40 # next two are for localuser.sh
41 #Requires: coreutils
42 Requires: xorg-x11-server-utils
43
44 %package session
45 Summary: Display manager support for ~/.xsession and ~/.Xclients
46 Group: User Interface/X
47
48 %description
49 X.Org X11 X Window System xinit startup scripts
50
51 %description session
52 Allows legacy ~/.xsession and ~/.Xclients files to be used from display managers
53
54 %prep
55 %setup -q
56 #%setup -q -n %{pkgname}-%{version}
57 #%patch1 -p1 -b .client-session
58 #%patch3 -p1 -b .unset
59
60 %build
61 autoreconf
62 ./configure --prefix=%{_prefix} CFLAGS="${CFLAGS} -g -D_F_EXIT_AFTER_XORG_AND_XCLIENT_LAUNCHED_ "
63
64 # FIXME: Upstream should default to XINITDIR being this.  Make a patch to
65 # Makefile.am and submit it in a bug report or check into CVS.
66 make %{?jobs:-j%jobs} XINITDIR=%{_sysconfdir}/X11/xinit
67
68 %install
69 # FIXME: Upstream should default to XINITDIR being this.  Make a patch to
70 # Makefile.am and submit it in a bug report or check into CVS.
71 #make install DESTDIR=$RPM_BUILD_ROOT XINITDIR=%{_sysconfdir}/X11/xinit
72 #install -p -m644 -D %{SOURCE18} $RPM_BUILD_ROOT%{_datadir}/xsessions/xinit-compat.desktop
73
74 make install DESTDIR=$RPM_BUILD_ROOT
75
76 # Install Red Hat custom xinitrc, etc.
77 #{
78 #    mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/X11/xinit
79 #
80 #    install -p -m 644 %{SOURCE10} $RPM_BUILD_ROOT%{_sysconfdir}/X11/xinit/xinitrc-common
81 #
82 #    for script in %{SOURCE11} %{SOURCE12} %{SOURCE16} ; do
83 #        install -p -m 755 $script $RPM_BUILD_ROOT%{_sysconfdir}/X11/xinit/${script##*/}
84 #    done
85 #
86 #    install -p -m 644 %{SOURCE13} $RPM_BUILD_ROOT%{_sysconfdir}/X11/Xmodmap
87 #    install -p -m 644 %{SOURCE14} $RPM_BUILD_ROOT%{_sysconfdir}/X11/Xresources
88 #
89 #    mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/X11/xinit/xinitrc.d
90 #    install -p -m 755 %{SOURCE17} $RPM_BUILD_ROOT%{_sysconfdir}/X11/xinit/xinitrc.d/localuser.sh
91 #
92 #    mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/X11/xinit/Xclients.d
93 #
94 #    mkdir -p $RPM_BUILD_ROOT%{_libexecdir}
95 #    install -p -m 755 %{SOURCE19} $RPM_BUILD_ROOT%{_libexecdir}
96 #}
97
98 %remove_docs
99
100 %files
101 %defattr(-,root,root,-)
102 #%doc COPYING README ChangeLog
103 #%{_bindir}/startx
104 %{_bindir}/xinit
105 #%dir %{_sysconfdir}/X11/xinit
106 #%{_sysconfdir}/X11/xinit/xinitrc
107 #%{_sysconfdir}/X11/xinit/xinitrc-common
108 #%config(noreplace) %{_sysconfdir}/X11/Xmodmap
109 #%config(noreplace) %{_sysconfdir}/X11/Xresources
110 #%dir %{_sysconfdir}/X11/xinit/Xclients.d
111 #%{_sysconfdir}/X11/xinit/Xclients
112 #%{_sysconfdir}/X11/xinit/Xsession
113 #%dir %{_sysconfdir}/X11/xinit/xinitrc.d
114 #%{_sysconfdir}/X11/xinit/xinitrc.d/*
115 #%{_mandir}/man1/startx.1*
116 #%{_mandir}/man1/xinit.1*
117
118 #%files session
119 #%defattr(-, root, root,-)
120 #%{_libexecdir}/xinit-compat
121 #%{_datadir}/xsessions/xinit-compat.desktop