3981f5ee374d4d317fe71f4128b5fa6ad11621b1
[framework/uifw/xorg/util/x11-utils.git] / packaging / xorg-x11-utils.spec
1 %define pkgname utils
2
3 Summary: X.Org X11 X client utilities
4 Name: xorg-x11-utils
5 Version: 7.5
6 Release: 6
7 License: MIT
8 Group: User Interface/X
9 URL: http://www.x.org
10 Source: %{name}-%{version}.tar.gz
11
12 BuildRequires: pkgconfig(dmx) pkgconfig(xext) pkgconfig(xft) pkgconfig(xrandr)
13 #BuildRequires: pkgconfig(dmx) pkgconfig(gl) pkgconfig(xext) pkgconfig(xft)
14 BuildRequires: pkgconfig(xi) pkgconfig(xinerama) pkgconfig(xmu)
15 BuildRequires: pkgconfig(xpm) pkgconfig(xt) pkgconfig(xtst) pkgconfig(xv)
16 BuildRequires: pkgconfig(xxf86dga) pkgconfig(xxf86vm)
17 BuildRequires: pkgconfig(xcb) pkgconfig(xcb-atom)
18
19 %define DEF_SUBDIRS xdpyinfo xev xlsatoms xlsclients xlsfonts xprop xvinfo xwininfo
20
21 Provides: %{DEF_SUBDIRS} edid-decode 
22
23 %description
24 A collection of client utilities which can be used to query the X server
25 for various information.
26
27 %prep
28 %setup -q
29
30 %build
31 # Build all apps
32 {
33     for app in %{DEF_SUBDIRS}; do
34         pushd $app
35         %configure \
36             --disable-xprint \
37             RSH=rsh \
38             MANCONF="/etc/manpath.config"
39         popd
40     done
41 }
42
43 %install
44 rm -rf $RPM_BUILD_ROOT
45 # Install all apps
46 {
47    for app in %{DEF_SUBDIRS} ; do
48       pushd $app
49       make install DESTDIR=$RPM_BUILD_ROOT
50       popd
51    done
52 }
53
54 %remove_docs
55
56 %clean
57 rm -rf $RPM_BUILD_ROOT
58
59 %files
60 %defattr(-,root,root,-)
61 #%doc
62 %{_bindir}/*
63 #%{_bindir}/edid-decode
64 #%{_bindir}/xdpyinfo
65 #%{_bindir}/xev
66 #%{_bindir}/xlsatoms
67 #%{_bindir}/xlsclients
68 #%{_bindir}/xlsfonts
69 #%{_bindir}/xprop
70 #%{_bindir}/xvinfo
71 #%{_bindir}/xwininfo
72 #%{_mandir}/man1/xdpyinfo.1*
73 #%{_mandir}/man1/xev.1*
74 #%{_mandir}/man1/xlsatoms.1*
75 #%{_mandir}/man1/xlsclients.1*
76 #%{_mandir}/man1/xlsfonts.1*
77 #%{_mandir}/man1/xprop.1*
78 #%{_mandir}/man1/xvinfo.1*
79 #%{_mandir}/man1/xwininfo.1*