Tizen 2.0 Release
[framework/uifw/xorg/util/x11-xserver-utils.git] / packaging / xorg-x11-server-utils.spec
1 %define _unpackaged_files_terminate_build 0 
2
3 %define pkgname server-utils
4 # doesn't work yet, needs more nickle bindings
5 %define with_xkeystone 0
6
7 Summary: X.Org X11 X server utilities
8 Name: xorg-x11-server-utils
9 Version: 7.5
10 Release: 12
11 License: MIT
12 Group: User Interface/X
13 URL: http://www.x.org
14 Source0: %{name}-%{version}.tar.gz
15 Source1: xmodmap.service
16 Source2: xrdb.service
17 Source3: xset-autorepeat-lb.service
18 Source4: xset-autorepeat-i386.service
19
20 # NOTE: Each upstream tarball has its own "PatchN" section, taken from
21 # multiplying the "SourceN" line times 100.  Please keep them in this
22 # order.  Also, please keep each patch specific to a single upstream tarball,
23 # so that they don't have to be split in half when submitting upstream.
24 #
25 # iceauth section
26 #Patch0: 
27
28 BuildRequires: xorg-x11-xutils-dev
29 #BuildRequires: pkgconfig(xorg-macros)
30 BuildRequires: pkgconfig(xmu) pkgconfig(xext) pkgconfig(xrandr)
31 BuildRequires: pkgconfig(xxf86vm) pkgconfig(xrender) pkgconfig(xi)
32 BuildRequires: pkgconfig(xt) pkgconfig(xpm)
33 # xsetroot requires xbitmaps-devel (which was renamed now)
34 BuildRequires: xorg-x11-xbitmaps
35 # xsetroot
36 BuildRequires: libXcursor-devel
37 # xinput
38 BuildRequires: libXinerama-devel
39
40 # xrdb, sigh
41 #Requires: mcpp
42 # older -apps had xinput and xkill, moved them here because they're
43 # a) universally useful and b) don't require Xaw
44 #Conflicts: xorg-x11-apps < 7.6-4
45
46 %define DEF_SUBDIRS iceauth rgb sessreg xgamma xhost xkill xmodmap xrandr xrdb xrefresh xset xsetmode xsetpointer xsetroot xstdcmap
47 Provides: %{DEF_SUBDIRS}
48 Provides: x11-xserver-utils = %{version}
49
50 %description
51 A collection of utilities used to tweak and query the runtime configuration
52 of the X server.
53
54 %if %{with_xkeystone}
55 %package -n xkeystone
56 Summary: X display keystone correction
57 Group: User Interface/X
58 Requires: nickle
59
60 %description -n xkeystone
61 Utility to perform keystone adjustments on X screens.
62 %endif
63
64 %package lb
65 Summary:        Device-specific files for Lunchbox
66 Group:          User Interface/X
67 Requires:       %{name} = %{version}
68 Provides:       x11-xserver-utils-lb = %{version}
69
70 %description lb
71 This package provides files for the X server utilities package that are
72 specific to Lunchbox devices.
73
74 %package i386
75 Summary:        Device-specific files for i386
76 Group:          User Interface/X
77 Requires:       %{name} = %{version}
78 Provides:       x11-xserver-utils-i386 = %{version}
79
80 %description i386
81 This package provides files for the X server utilities package that are
82 specific to i386/emulator devices.
83
84
85 %prep
86 %setup -q
87
88 %build
89 # Build all apps
90 export CFLAGS+=" -D_GNU_SOURCE"
91 {
92     for app in %{DEF_SUBDIRS}; do
93         pushd $app
94         %configure \
95             --disable-xprint \
96             RSH=rsh \
97             MANCONF="/etc/manpath.config"
98         make
99         popd
100     done
101 }
102
103 %install
104 rm -rf $RPM_BUILD_ROOT
105 mkdir -p %{buildroot}/usr/share/license
106 cp -af COPYING %{buildroot}/usr/share/license/%{name}
107 # Install all apps
108 {
109    for app in %{DEF_SUBDIRS} ; do
110       pushd $app
111       make install DESTDIR=$RPM_BUILD_ROOT
112       popd
113    done
114 }
115
116 mkdir -p %{buildroot}%{_libdir}/systemd/user/core-efl.target.wants
117 install -m 0644 %SOURCE1 %{buildroot}%{_libdir}/systemd/user/
118 install -m 0644 %SOURCE2 %{buildroot}%{_libdir}/systemd/user/
119 install -m 0644 %SOURCE3 %{buildroot}%{_libdir}/systemd/user/
120 install -m 0644 %SOURCE4 %{buildroot}%{_libdir}/systemd/user/
121 ln -s ../xmodmap.service %{buildroot}%{_libdir}/systemd/user/core-efl.target.wants/xmodmap.service
122 ln -s ../xrdb.service %{buildroot}%{_libdir}/systemd/user/core-efl.target.wants/xrdb.service
123 ln -s ../xset-autorepeat-lb.service %{buildroot}%{_libdir}/systemd/user/core-efl.target.wants/xset-autorepeat-lb.service
124 ln -s ../xset-autorepeat-i386.service %{buildroot}%{_libdir}/systemd/user/core-efl.target.wants/xset-autorepeat-i386.service
125
126 %remove_docs
127
128 %clean
129 rm -rf $RPM_BUILD_ROOT
130
131 %files
132 %defattr(-,root,root,-)
133 /usr/share/license/%{name}
134 %doc
135 %{_bindir}/iceauth
136 %{_bindir}/sessreg
137 %{_bindir}/showrgb
138 %{_bindir}/xgamma
139 %{_bindir}/xhost
140 %{_bindir}/xkill
141 %{_bindir}/xmodmap
142 %{_bindir}/xrandr
143 %{_bindir}/xrdb
144 %{_bindir}/xrefresh
145 %{_bindir}/xset
146 %{_bindir}/xsetmode
147 %{_bindir}/xsetpointer
148 %{_bindir}/xsetroot
149 %{_bindir}/xstdcmap
150 %{_datadir}/X11/rgb.txt
151 %{_libdir}/systemd/user/xmodmap.service
152 %{_libdir}/systemd/user/xrdb.service
153 %{_libdir}/systemd/user/core-efl.target.wants/xmodmap.service
154 %{_libdir}/systemd/user/core-efl.target.wants/xrdb.service
155
156 %if %{with_xkeystone}
157 %files -n xkeystone
158 %defattr(-,root,root,-)
159 %{_bindir}/xkeystone
160 %endif
161
162 %files lb
163 %{_libdir}/systemd/user/xset-autorepeat-lb.service
164 %{_libdir}/systemd/user/core-efl.target.wants/xset-autorepeat-lb.service
165
166 %files i386
167 %{_libdir}/systemd/user/xset-autorepeat-i386.service
168 %{_libdir}/systemd/user/core-efl.target.wants/xset-autorepeat-i386.service