tizen 2.3.1 release
[framework/uifw/xorg/proto/x11proto-fixes.git] / packaging / xorg-x11-proto-fixes.spec
1 Name:     xorg-x11-proto-fixes
2 Summary:  X.Org X11 Protocol fixesproto
3 Version:  5.0
4 Release:  2
5 Group:    Development/System
6 License:  MIT
7 URL:      http://www.x.org
8 Source0:  %{name}-%{version}.tar.gz
9 Provides: fixesproto
10
11 BuildRequires: pkgconfig
12 BuildRequires: pkgconfig(xorg-macros)
13
14 Requires: xextproto
15
16 # some file to be intalled can be ignored when rpm generates packages
17 %define _unpackaged_files_terminate_build 0
18
19 %description
20 Description: %{summary}
21
22 %prep
23 %setup -q
24
25 %build
26
27 ./autogen.sh
28 %reconfigure --disable-static \
29              --libdir=%{_datadir} \
30              --without-xmlto
31
32 # Call make instruction with smp support
33 make %{?jobs:-j%jobs}
34
35 %install
36 rm -rf %{buildroot}
37 %make_install
38
39 %remove_docs
40
41 %clean
42 rm -rf %{buildroot}
43
44 %files
45 %defattr(-,root,root,-)
46 %{_includedir}/X11/extensions/*.h
47 %{_datadir}/pkgconfig/*.pc