Tizen 2.1 base
[framework/uifw/xorg/proto/x11proto-fixes.git] / packaging / xorg-x11-proto-fixes.spec
1 Name:     xorg-x11-proto-fixes
2 Summary:  X.Org X11 Protocol fixesproto
3 Version:  5.0
4 Release:  2
5 Group:    Development/System
6 License:  MIT
7 URL:      http://www.x.org
8 Source0:  %{name}-%{version}.tar.gz
9 Provides: fixesproto
10
11
12 BuildRequires: pkgconfig
13 BuildRequires: pkgconfig(xorg-macros)
14
15 Requires: xextproto
16
17 # some file to be intalled can be ignored when rpm generates packages
18 %define _unpackaged_files_terminate_build 0
19
20 %description
21 Description: %{summary}
22
23 %prep
24 %setup -q
25
26 %build
27
28 ./autogen.sh
29 %reconfigure --disable-static \
30              --libdir=%{_datadir} \
31              --without-xmlto
32
33 # Call make instruction with smp support
34 make %{?jobs:-j%jobs}
35
36 %install
37 rm -rf %{buildroot}
38 %make_install
39
40 %remove_docs
41
42 %clean
43 rm -rf %{buildroot}
44
45 %files
46 %defattr(-,root,root,-)
47 %{_includedir}/X11/extensions/*.h
48 %{_datadir}/pkgconfig/*.pc