package version up
[platform/adaptation/samsung_exynos/xf86-misc-exynos4412.git] / packaging / xorg-x11-misc-exynos.spec
1 #sbs-git:slp/pkgs/xorg/driver/xserver-xorg-misc xserver-xorg-misc 0.0.1 13496ac354ad7f6709f1ef9b880a206a2df41c80
2 Name:   xorg-x11-misc-exynos
3 Summary:    X11 X server misc files for exynos
4 Version:    0.0.18
5 Release:    1
6 ExclusiveArch:  %arm
7 Group:      System/X11
8 License:    MIT
9 Source0:    %{name}-%{version}.tar.gz
10 Source1:    xresources.service
11
12 Requires:   xserver-xorg-core
13 Requires:   xorg-x11-drv-evdev-multitouch
14 Requires(post):   xkeyboard-config
15
16 %description
17 Description: %{summary}
18
19
20 %prep
21 %setup -q
22
23
24 %build
25 {
26 for f in `find arm-common/ -name "*.in"`; do
27         cat $f > ${f%.in};
28         sed -i -e "s#@PREFIX@#/usr#g" ${f%.in};
29         sed -i -e "s#@DATADIR@#/opt#g" ${f%.in};
30         chmod a+x ${f%.in};
31 done
32 }
33
34 %reconfigure \
35         --with-arch=arm \
36         --with-conf-prefix=/
37
38 make %{?jobs:-j%jobs}
39
40 %install
41 rm -rf %{buildroot}
42 mkdir -p %{buildroot}/usr/share/license
43 cp -af COPYING %{buildroot}/usr/share/license/%{name}
44 %make_install
45
46 mkdir -p %{buildroot}/etc/rc.d/init.d/
47 mkdir -p %{buildroot}/etc/rc.d/rc3.d/
48 mkdir -p %{buildroot}/etc/rc.d/rc4.d/
49 mkdir -p %{buildroot}/etc/profile.d/
50 mkdir -p %{buildroot}/etc/X11/
51 cp -af arm-common/xserver %{buildroot}/etc/rc.d/init.d/
52 cp -af arm-common/xresources %{buildroot}/etc/rc.d/init.d/
53 cp -af arm-common/xsetrc %{buildroot}/etc/X11/
54 cp -af arm-common/Xmodmap %{buildroot}/etc/X11/
55 cp -af arm-common/xinitrc %{buildroot}/etc/X11/
56 ln -s /etc/rc.d/init.d/xserver %{buildroot}/etc/rc.d/rc3.d/S02xserver
57 ln -s /etc/rc.d/init.d/xserver %{buildroot}/etc/rc.d/rc4.d/S02xserver
58 ln -s /etc/rc.d/init.d/xresources %{buildroot}/etc/rc.d/rc4.d/S80xresources
59 cp -af arm-common/Xorg.sh %{buildroot}/etc/profile.d/
60 mkdir -p %{buildroot}%{_libdir}/systemd/system/multi-user.target.wants
61 install -m 0644 %SOURCE1 %{buildroot}%{_libdir}/systemd/system/xresources.service
62 ln -s ../xresources.service %{buildroot}%{_libdir}/systemd/system/multi-user.target.wants/xresources.service
63
64 cp -rf arm-e4412/* %{buildroot}/etc/X11/
65
66 %post
67 mkdir -p /opt/var/log
68
69 %files
70 %manifest xorg-x11-misc-exynos.manifest
71 %defattr(-,root,root,-)
72 /usr/share/license/%{name}
73 %{_sysconfdir}/profile.d/Xorg.sh
74 %{_sysconfdir}/rc.d/init.d/*
75 %{_sysconfdir}/rc.d/rc3.d/*
76 %{_sysconfdir}/rc.d/rc4.d/*
77 %attr(-,inhouse,inhouse)
78 /etc/X11/Xresources
79 /etc/X11/xinitrc
80 /etc/X11/xsetrc
81 /etc/X11/Xmodmap
82 /etc/X11/xorg.conf
83 /etc/X11/xorg.conf.d/*.conf
84 %{_bindir}/startx
85 %{_libdir}/systemd/system/xresources.service
86 %{_libdir}/systemd/system/multi-user.target.wants/xresources.service
87