tizen 2.4 release
[adaptation/xorg/driver/xserver-xorg-input-evdev.git] / packaging / xorg-x11-drv-evdev.spec
1 #sbs-git:slp/pkgs/xorg/driver/xserver-xorg-input-evdev xserver-xorg-input-evdev 2.3.2 1bd95071427e460187b090bc5ff5a2d880fe156a
2 Name:   xorg-x11-drv-evdev
3 Summary:    Xorg X11 evdev input driver
4 Version: 2.7.6.19
5 Release:    3
6 Group:      System/X Hardware Support
7 License:    MIT
8 URL:        http://www.x.org/
9 Source0:    %{name}-%{version}.tar.gz
10 #Requires:   xorg-server
11 Requires:   xorg-x11-server-Xorg
12 BuildRequires:  pkgconfig(xorg-macros)
13 BuildRequires:  pkgconfig(xorg-server)
14 BuildRequires:  pkgconfig(xkbfile)
15 BuildRequires:  pkgconfig(inputproto)
16 BuildRequires:  pkgconfig(libudev)
17 BuildRequires:  pkgconfig(mtdev)
18 BuildRequires:  pkgconfig(ttrace)
19 Requires:  libudev
20 Requires:  mtdev
21
22 %description
23 The Xorg X11 evdev input driver
24
25
26 %package devel
27 Summary:    Development files for xorg evdev driver
28 Group:      Development/Libraries
29 Requires:   %{name} = %{version}-%{release}
30
31 %description devel
32 This package contains xorg evdev development files
33
34
35 %prep
36 %setup -q
37
38 %build
39 %autogen
40
41 %if "%{?tizen_profile_name}" == "mobile"
42 export CFLAGS+=" -D_ENV_MOBILE_"
43 %else
44 %if "%{?tizen_profile_name}" == "wearable"
45 export CFLAGS+=" -D_ENV_WEARABLE_ -D_F_SUPPORT_ROTATION_ANGLE_ -D_F_EVDEV_SUPPORT_ROTARY_"
46 %else
47 %if "%{?tizen_profile_name}" == "tv"
48 export CFLAGS+=" -D_ENV_TV_ -D_F_PROXY_DEVICE_ENABLED_ -D_F_EVDEV_SUPPORT_SMARTRC_"
49 export CFLAGS+=" -D_F_PICTURE_OFF_MODE_ENABLE_ -D_F_DONOT_SEND_RMA_BTN_RELEASE_ -D_F_PROXY_DEVICE_CHANGE_SOURCE_ID"
50 export CFLAGS+=" -D_F_BLOCK_MOTION_DEVICE_ -D_F_BOOST_PULSE_ -D_F_REMAP_KEYS_ -D_F_SMART_RC_CHG_KBD_SRC_DEV_ "
51 %endif
52 %endif
53 %endif
54 %reconfigure --disable-static CFLAGS="$CFLAGS -Wall -g -D_F_EVDEV_CONFINE_REGION_ -D_F_ENABLE_DEVICE_TYPE_PROP_ -D_F_GESTURE_EXTENSION_ -D_F_TOUCH_TRANSFORM_MATRIX_ -D_F_ENABLE_REL_MOVE_STATUS_PROP_ -D_F_EVDEV_SUPPORT_GAMEPAD -D_F_USE_DEFAULT_XKB_RULES_ "
55
56 make %{?jobs:-j%jobs}
57
58 %install
59 rm -rf %{buildroot}
60 mkdir -p %{buildroot}/usr/share/license
61 cp -af COPYING %{buildroot}/usr/share/license/%{name}
62 %make_install
63
64 %remove_docs
65
66 %files
67 %defattr(-,root,root,-)
68 %(pkg-config xorg-server --variable=moduledir )/input/evdev_drv.so
69 /usr/share/license/%{name}
70
71 %files devel
72 %defattr(-,root,root,-)
73 %{_includedir}/xorg/evdev-properties.h
74 %{_libdir}/pkgconfig/xorg-evdev.pc