0a884acfc9b66678f5e5d29979bb9b1600be909c
[adaptation/xorg/driver/xserver-xorg-input-evdev.git] / packaging / xorg-x11-drv-evdev.spec
1 #sbs-git:slp/pkgs/xorg/driver/xserver-xorg-input-evdev xserver-xorg-input-evdev 2.3.2 1bd95071427e460187b090bc5ff5a2d880fe156a
2 Name:   xorg-x11-drv-evdev
3 Summary:    Xorg X11 evdev input driver
4 Version: 2.7.6.11
5 Release:    3
6 Group:      System/X Hardware Support
7 License:    MIT
8 URL:        http://www.x.org/
9 Source0:    %{name}-%{version}.tar.gz
10 #Requires:   xorg-server
11 Requires:   xorg-x11-server-Xorg
12 BuildRequires:  pkgconfig(xorg-macros)
13 BuildRequires:  xorg-x11-server-devel
14 #BuildRequires:  pkgconfig(xorg-server)
15 BuildRequires:  pkgconfig(xkbfile)
16 BuildRequires:  pkgconfig(xproto)
17 BuildRequires:  pkgconfig(inputproto)
18 BuildRequires:  pkgconfig(xrandr)
19 BuildRequires:  pkgconfig(randrproto)
20 BuildRequires:  pkgconfig(xextproto)
21 BuildRequires:  pkgconfig(resourceproto)
22 BuildRequires:  pkgconfig(libudev)
23 BuildRequires:  pkgconfig(mtdev)
24 BuildRequires:  model-build-features
25 Requires:  libudev
26 Requires:  mtdev
27
28 %description
29 The Xorg X11 evdev input driver
30
31
32 %package devel
33 Summary:    Development files for xorg evdev driver
34 Group:      Development/Libraries
35 Requires:   %{name} = %{version}-%{release}
36
37 %description devel
38 This package contains xorg evdev development files
39
40
41 %prep
42 %setup -q
43
44 %build
45 %autogen
46
47 %if "%{?tizen_profile_name}" == "mobile"
48 export CFLAGS+=" -D_ENV_MOBILE_"
49 %else
50 %if "%{?tizen_profile_name}" == "wearable"
51 export CFLAGS+=" -D_ENV_WEARABLE_"
52 %if "%{?model_build_feature_formfactor}" == "circle"
53 export CFLAGS+=" -D_F_EVDEV_SUPPORT_ROTARY_"
54 %endif
55 %endif
56 %endif
57 %reconfigure --disable-static CFLAGS="$CFLAGS -Wall -g -D_F_EVDEV_CONFINE_REGION_ -D_F_ENABLE_DEVICE_TYPE_PROP_ -D_F_GESTURE_EXTENSION_ -D_F_TOUCH_TRANSFORM_MATRIX_ -D_F_ENABLE_REL_MOVE_STATUS_PROP_ -D_F_EVDEV_SUPPORT_GAMEPAD -D_F_USE_DEFAULT_XKB_RULES_ "
58 make %{?jobs:-j%jobs}
59
60 %install
61 rm -rf %{buildroot}
62 mkdir -p %{buildroot}/usr/share/license
63 cp -af COPYING %{buildroot}/usr/share/license/%{name}
64 %make_install
65
66 %remove_docs
67
68 %files
69 %defattr(-,root,root,-)
70 %(pkg-config xorg-server --variable=moduledir )/input/evdev_drv.so
71 /usr/share/license/%{name}
72
73 %files devel
74 %defattr(-,root,root,-)
75 %{_includedir}/xorg/evdev-properties.h
76 %{_libdir}/pkgconfig/xorg-evdev.pc