Tizen 2.1 base
[adaptation/xorg/driver/xserver-xorg-video-emulfb.git] / packaging / xorg-x11-drv-emulfb.spec
1 # >> macros
2 # << macros
3
4 Name:       xorg-x11-drv-emulfb
5 Summary:    X.Org X server driver for sdk emulation
6 Version:    0.5.6
7 Release:    1
8 #ExclusiveArch:  %arm
9 Group:      System/X Hardware Support
10 License:    Samsung
11 Source0:    %{name}-%{version}.tar.gz
12
13 BuildRequires:  prelink
14 BuildRequires:  xorg-x11-xutils-dev
15 BuildRequires:  pkgconfig(xorg-server)
16 BuildRequires:  pkgconfig(randrproto)
17 BuildRequires:  pkgconfig(renderproto)
18 BuildRequires:  pkgconfig(fontsproto)
19 BuildRequires:  pkgconfig(xproto)
20 BuildRequires:  pkgconfig(videoproto)
21 BuildRequires:  pkgconfig(resourceproto)
22 BuildRequires:  pkgconfig(dlog)
23 BuildRequires:  pkgconfig(libdrm)
24 BuildRequires:  pkgconfig(pixman-1)
25
26 %description
27 This package provides the driver for sdk emulation
28
29 %prep
30 %setup -q
31
32 # >> setup
33 # << setup
34
35 %build
36 # >> build pre
37 # << build pre
38
39 %ifarch %{arm}
40 %define ENABLE_ARM --enable-arm
41 %else
42 %define ENABLE_ARM --disable-arm
43 %endif
44
45 %reconfigure --disable-static %{ENABLE_ARM} \
46     CFLAGS="-Wall -Werror ${CFLAGS}" LDFLAGS="${LDFLAGS} -Wl,--hash-style=both -Wl,--as-needed"
47
48 make %{?jobs:-j%jobs}
49
50 # >> build post
51 # << build post
52 %install
53 rm -rf %{buildroot}
54 # >> install pre
55 # << install pre
56 mkdir -p %{buildroot}/usr/share/license
57 cp -af COPYING %{buildroot}/usr/share/license/%{name}
58 %make_install
59
60 # >> install post
61 execstack -c %{buildroot}%{_libdir}/xorg/modules/drivers/emulfb_drv.so
62 # << install post
63
64 %files
65 %defattr(-,root,root,-)
66 # >> files emulfb
67 %{_libdir}/xorg/modules/drivers/*.so
68 %{_datadir}/man/man4/*
69 # << files emulfb
70 /usr/share/license/%{name}