fbf4057c19569fa60d98d7e1b1dcc4eaf8b24b14
[platform/upstream/xorg-cf-files.git] / packaging / xorg-cf-files.spec
1 Name:           xorg-cf-files
2 Version:        1.0.4
3 Release:        0
4 License:        MIT
5 Summary:        Data files for the imake utility
6 Url:            http://xorg.freedesktop.org/
7 Group:          Development/Tools/Building
8 Source0:        http://xorg.freedesktop.org/releases/individual/util/%{name}-%{version}.tar.bz2
9 BuildRequires:  font-util >= 1.1
10 BuildRequires:  pkgconfig(xorg-macros) >= 1.4
11 Requires:       gccmakedep
12 Requires:       imake
13 Requires:       makedepend
14 # This was part of the xorg-x11-util-devel package up to version 7.6
15 BuildArch:      noarch
16
17 %description
18 The xorg-cf-files package contains the data files for the imake utility,
19 defining the known settings for a wide variety of platforms (many of
20 which have not been verified or tested in over a decade), and for many
21 of the libraries formerly delivered in the X.Org monolithic releases.
22
23 The X Window System used imake extensively up through the X11R6.9
24 release, for both full builds within the source tree and external
25 software. X has since moved to GNU autoconf and automake for its build
26 system in X11R7.0 and later releases, but still maintains imake for
27 building existing external software programs that have not yet
28 converted.
29
30 %define _configdir %{_datadir}/X11/config
31
32 %prep
33 %setup -q
34 cat > host.def << EOF
35 #define ConfigDir %_configdir
36 #define XAppLoadDir /usr/share/X11/app-defaults
37 #define UseSeparateConfDir NO
38 #define ManPath /usr/share/man
39 %ifarch ppc64 s390x x86_64 sparc64
40 #define ModuleDir /usr/lib64/xorg/modules
41 %else
42 #define ModuleDir /usr/lib/xorg/modules
43 %endif
44 #ifdef  i386Architecture
45 #undef  DefaultGcc2i386Opt
46 #define DefaultGcc2i386Opt      %{optflags} -fno-strict-aliasing
47 #endif
48 #ifdef  MipsArchitecture
49 #undef  DefaultGcc2MipsOpt
50 #define DefaultGcc2MipsOpt      %{optflags} -fno-strict-aliasing
51 #endif
52 #ifdef  PpcArchitecture
53 #undef  DefaultGcc2PpcOpt
54 #define DefaultGcc2PpcOpt       %{optflags} -fno-strict-aliasing
55 #endif
56 #ifdef  Ppc64Architecture
57 #undef  DefaultGcc2Ppc64Opt
58 #define DefaultGcc2Ppc64Opt     %{optflags} -fno-strict-aliasing
59 #endif
60 #ifdef  AMD64Architecture
61 #undef  DefaultGcc2AMD64Opt
62 #define DefaultGcc2AMD64Opt     %{optflags} -fno-strict-aliasing
63 #endif
64 #ifdef  s390xArchitecture
65 #undef  OptimizedCDebugFlags
66 #define OptimizedCDebugFlags    %{optflags} -fno-strict-aliasing
67 #endif
68 #ifdef  ia64Architecture
69 #undef  OptimizedCDebugFlags
70 #define OptimizedCDebugFlags    %{optflags} -fno-strict-aliasing
71 #endif
72 #if defined(SparcArchitecture) || defined(Sparc64Architecture)
73 #undef  OptimizedCDebugFlags
74 #define OptimizedCDebugFlags    %{optflags} -fno-strict-aliasing
75 # undef HaveLib64
76 #if defined(Sparc64Architecture)
77 # define HaveLib64    YES
78 #else
79 # define HaveLib64    NO
80 #endif
81 #endif
82 EOF
83
84 %build
85 %configure --with-config-dir=%_configdir
86 make %{?_smp_mflags}
87
88 %install
89 %make_install
90
91 %files
92 %defattr(-,root,root)
93 %doc ChangeLog COPYING README
94 %dir %{_datadir}/X11
95 %{_datadir}/X11/config/
96
97 %changelog