upload source
[external/xmlsec1.git] / packaging / xmlsec1.spec
1 #sbs-git:slp/pkgs/x/xmlsec1 xmlsec1 1.2.14 bd7cd922035219f41232d25d9eaf5a2894474165
2
3 Name:       xmlsec1
4 Summary:    Library providing support for "XML Signature" and "XML Encryption" standards
5 Version: 1.2.14
6 Release:    1
7 Group:      System/Libraries
8 License:    MIT
9 URL:        http://www.aleksey.com/xmlsec/index.html
10 Source0:    http://www.aleksey.com/xmlsec/download/xmlsec1-%{version}.tar.gz
11 Requires(post): /sbin/ldconfig
12 Requires(postun): /sbin/ldconfig
13 BuildRequires:  pkgconfig(libxml-2.0) >= 2.6.27
14 BuildRequires:  pkgconfig(libxslt)
15 BuildRequires:  pkgconfig(openssl)
16
17
18 %description
19 This C library allows to transform XML files into other XML files
20 (or HTML, text, ...) using the standard XSLT stylesheet transformation
21 mechanism. To use it you need to have a version of libxml2 >= 2.6.27
22 installed. The xsltproc command is a command line interface to the XSLT engine
23
24
25
26 %package openssl
27 Summary:    OpenSSL crypto plugin for XML Security Library
28 Group:      System/Libraries
29 Requires:   %{name} = %{version}-%{release}
30 Requires(post): /sbin/ldconfig
31 Requires(postun): /sbin/ldconfig
32
33 %description openssl
34 OpenSSL plugin for XML Security Library provides OpenSSL based crypto services
35 for the xmlsec library.
36
37
38 %package devel
39 Summary:    Libraries, includes, etc. to develop applications with XML Digital Signatures and XML Encryption support.
40 Group:      Development/Libraries
41 Requires:   %{name} = %{version}-%{release}
42
43 %description devel
44 This C library allows to transform XML files into other XML files
45 (or HTML, text, ...) using the standard XSLT stylesheet transformation
46 mechanism. To use it you need to have a version of libxml2 >= 2.6.27
47 installed.
48
49
50
51 %prep
52 %setup -q -n %{name}-%{version}
53
54
55 %build
56
57 %configure --disable-static \
58     --enable-dynamic --disable-crypto-dl --disable-apps-crypto-dl --without-gnutls
59
60 make %{?jobs:-j%jobs}
61
62 %install
63 rm -rf %{buildroot}
64 %make_install
65
66
67
68
69 %post -p /sbin/ldconfig
70
71 %postun -p /sbin/ldconfig
72
73
74
75 %post openssl -p /sbin/ldconfig
76
77 %postun openssl -p /sbin/ldconfig
78
79
80
81
82 %files
83 %defattr(-,root,root,-)
84 %doc Copyright AUTHORS README NEWS ChangeLog
85 %{_libdir}/libxmlsec1.so.*
86 /usr/bin/xmlsec1
87 /usr/share/man/man1/xmlsec1.1.gz
88
89
90 %files openssl
91 %defattr(-,root,root,-)
92 %{_libdir}/libxmlsec1-openssl.so.*
93
94 %files devel
95 %defattr(-,root,root,-)
96 %doc Copyright ChangeLog AUTHORS README NEWS TODO
97 /usr/include/*
98 /usr/bin/xmlsec1-config
99 %{_libdir}/lib*.so
100 %{_libdir}/pkgconfig/*
101 %{_libdir}/xmlsec1Conf.sh
102 /usr/share/doc/xmlsec1/*
103 /usr/share/man/man1/xmlsec1-config.1.gz
104 /usr/share/aclocal/xmlsec1.m4
105