fix package name
[platform/adaptation/samsung_exynos/xf86-misc-exynos4412.git] / packaging / xf86-misc-exynos4412.spec
1 #sbs-git:slp/pkgs/xorg/driver/xserver-xorg-misc xserver-xorg-misc 0.0.1 13496ac354ad7f6709f1ef9b880a206a2df41c80
2 Name:   xf86-misc-exynos4412
3 Summary:    X11 X server misc files for exynos
4 Version:    0.0.20
5 Release:    1
6 ExclusiveArch:  %arm
7 Group:      System/X11
8 License:    MIT
9 Source0:    %{name}-%{version}.tar.gz
10 Source1:    xresources.service
11 Source2:    xresources.path
12
13 Requires:   xorg-server
14 Requires:   xf86-input-evdevmultitouch
15 Requires(post):   xkeyboard-config
16
17 %description
18 Description: %{summary}
19
20
21 %prep
22 %setup -q
23
24
25 %build
26 {
27 for f in `find arm-common/ -name "*.in"`; do
28         cat $f > ${f%.in};
29         sed -i -e "s#@PREFIX@#/usr#g" ${f%.in};
30         sed -i -e "s#@DATADIR@#/opt#g" ${f%.in};
31         chmod a+x ${f%.in};
32 done
33 }
34
35 %reconfigure \
36         --with-arch=arm \
37         --with-conf-prefix=/
38
39 make %{?jobs:-j%jobs}
40
41 %install
42 rm -rf %{buildroot}
43 mkdir -p %{buildroot}/usr/share/license
44 cp -af COPYING %{buildroot}/usr/share/license/%{name}
45 %make_install
46
47 mkdir -p %{buildroot}/etc/rc.d/init.d/
48 mkdir -p %{buildroot}/etc/rc.d/rc3.d/
49 mkdir -p %{buildroot}/etc/rc.d/rc4.d/
50 mkdir -p %{buildroot}/etc/profile.d/
51 mkdir -p %{buildroot}/etc/X11/
52 cp -af arm-common/xserver %{buildroot}/etc/rc.d/init.d/
53 cp -af arm-common/xresources %{buildroot}/etc/rc.d/init.d/
54 cp -af arm-common/xsetrc %{buildroot}/etc/X11/
55 cp -af arm-common/Xmodmap %{buildroot}/etc/X11/
56 cp -af arm-common/xinitrc %{buildroot}/etc/X11/
57 ln -s /etc/rc.d/init.d/xserver %{buildroot}/etc/rc.d/rc3.d/S02xserver
58 ln -s /etc/rc.d/init.d/xserver %{buildroot}/etc/rc.d/rc4.d/S02xserver
59 ln -s /etc/rc.d/init.d/xresources %{buildroot}/etc/rc.d/rc4.d/S80xresources
60 cp -af arm-common/Xorg.sh %{buildroot}/etc/profile.d/
61 mkdir -p %{buildroot}%{_libdir}/systemd/system/graphical.target.wants
62 install -m 0644 %SOURCE1 %{buildroot}%{_libdir}/systemd/system/xresources.service
63 install -m 0644 %SOURCE2 %{buildroot}%{_libdir}/systemd/system/xresources.path
64 ln -s ../xresources.path %{buildroot}%{_libdir}/systemd/system/graphical.target.wants/
65
66 cp -rf arm-e4412/* %{buildroot}/etc/X11/
67
68 %post
69 mkdir -p /opt/var/log
70
71 %files
72 %manifest xorg-x11-misc-exynos.manifest
73 %defattr(-,root,root,-)
74 /usr/share/license/%{name}
75 %{_sysconfdir}/profile.d/Xorg.sh
76 %{_sysconfdir}/rc.d/init.d/*
77 %{_sysconfdir}/rc.d/rc3.d/*
78 %{_sysconfdir}/rc.d/rc4.d/*
79 %attr(-,inhouse,inhouse)
80 /etc/X11/Xresources
81 /etc/X11/xinitrc
82 /etc/X11/xsetrc
83 /etc/X11/Xmodmap
84 /etc/X11/xorg.conf
85 /etc/X11/xorg.conf.d/*.conf
86 %{_bindir}/startx
87 %{_libdir}/systemd/system/xresources.service
88 %{_libdir}/systemd/system/xresources.path
89 %{_libdir}/systemd/system/graphical.target.wants/xresources.path
90