xcb-util should not try to build into a pure wayland platform.
[platform/upstream/xcb-util.git] / packaging / xcb-util.spec
1 %bcond_with x
2
3 Name:           xcb-util
4 Version:        0.3.9
5 Release:        0
6 License:        MIT
7 Summary:        Utility libraries for X C Binding
8 Url:            http://xcb.freedesktop.org/
9 Group:          Graphics/X Window System
10 Source:         %{name}-%{version}.tar.bz2
11 Source1001:     xcb-util.manifest
12
13 BuildRequires:  gperf
14 BuildRequires:  libxcb-devel >= 1.4
15 BuildRequires:  m4
16 BuildRequires:  pkgconfig(xorg-macros)
17 BuildRequires:  pkgconfig(xproto)
18
19 %if !%{with x}
20 ExclusiveArch:
21 %endif
22
23 %description
24 The xcb-util module provides a number of libraries which sit on top of
25 libxcb, the core X protocol library, and some of the extension
26 libraries. These experimental libraries provide convenience functions
27 and interfaces which make the raw X protocol more usable. Some of the
28 libraries also provide client-side code which is not strictly part of
29 the X protocol but which have traditionally been provided by Xlib.
30
31 %package -n libxcb-util
32 Summary:        XCB utility modules
33 Group:          Graphics/X Window System
34
35 %description -n libxcb-util
36 The XCB util modules provide a number of libraries which sit on top
37 of libxcb, the core X protocol library, and some of the extension
38 libraries. These experimental libraries provide convenience functions
39 and interfaces which make the raw X protocol more usable. Some of the
40 libraries also provide client-side code which is not strictly part of
41 the X protocol but which have traditionally been provided by Xlib.
42
43 Included in this package are:
44
45 - atom: Standard core X atom constants and atom caching.
46 - aux: Convenient access to connection setup and some core requests.
47 - event: Callback X event handling.
48
49 %package        devel
50 Summary:        Development and header files for xcb-util
51 Group:          Development/Libraries
52 Requires:       libxcb-util = %{version}
53 Requires:       pkgconfig
54
55 %description    devel
56 Development files for xcb-util.
57
58 %prep
59 %setup -q
60 cp %{SOURCE1001} .
61
62 %build
63 %configure --disable-static
64
65 make %{?_smp_mflags}
66
67 %install
68 %make_install
69
70 %remove_docs
71
72 %post -n libxcb-util -p /sbin/ldconfig
73
74 %postun -n libxcb-util -p /sbin/ldconfig
75
76
77 %files -n libxcb-util
78 %manifest %{name}.manifest
79 %defattr(-,root,root,-)
80 %{_libdir}/libxcb-util.so.*
81
82 %files devel
83 %manifest %{name}.manifest
84 %defattr(-,root,root,-)
85 %{_libdir}/pkgconfig/*.pc
86 %{_libdir}/*.so
87 %{_includedir}/xcb/*.h